Difference between revisions of "User talk:Bamaustin"

From Gramps
Jump to: navigation, search
m
m (First binary for Apple Mac: Long live the Queen!)
 
(91 intermediate revisions by 8 users not shown)
Line 1: Line 1:
'''Welcome to ''Gramps''!'''
+
<!-- Policy: comment the Languages bar until at least ONE additional translation is available
We hope you will contribute much and well.
+
{{Languages}} 
You will probably want to read the [https://www.mediawiki.org/wiki/Special:MyLanguage/Help:Contents help pages].
+
-->{{Third-party plugin}}
Again, welcome and have fun! [[User:Sam888|Sam888]] ([[User talk:Sam888|talk]]) 01:21, 5 July 2018 (UTC)
+
{{man warn|1=&#x1F6A7; Unreleased add-on|2=You may install the addon manually if you are interested in helping to test and report issues.<br />Beta testing involves a significant risk of data loss and corruption. Make a ''well-labeled'' backup frequently.}}
  
 +
{{man warn|1=&#x1F6A7; Work In Progress|2=This wikipage is a cloned outline from a template. It is a VERY temporary placeholder in my personal discussion area.
  
==Screenshots==
+
Since you are reading '''''this paragraph''''', then the I have not progressed to the point of trimming out the excess template material. That means the wikipage is certainly not ready for collaborative editing yet. Multiple people editing ''now'' might unintentionally overwrite their work. Contact me via the Discourse discussion forum while this page exists as a 'Discussion' page.}}
Hi , Thanks for your screenshot for the user manual, sorry that I've had to revert it as all screenshots in the user manual are taken from the example.gramps family tree. I suggest note N009 or a new note as N009 already exist in example.gramps be updated (in gramps master for the Gramps 5.1 release) to show the links etc, then it can be added to the user manual. [[User:Sam888|Sam888]] ([[User talk:Sam888|talk]]) 22:20, 18 March 2019 (UTC)
+
== See also ==
:: Or seeing as you want to show the linking feature we do use the existing N009 note from example.gramps and nothing else needs to be done, what do you think? [[User:Sam888|Sam888]] ([[User talk:Sam888|talk]]) 22:29, 18 March 2019 (UTC)
+
* [https://github.com/cdhorn/CardView CardView folder] in Christopher Horn's GitHub Repository
 
+
* [https://github.com/cdhorn/CardView/blob/master/README.md CardView README.md] on GitHub
== Sandbox ==
+
* [[Addon:CardView|Addon:CardView]] - addon Wiki page
 
+
* [[Addon:LinkedView|Addon:LinkedView]] : superseded <small>(submit to [[:Category:Deletion_request|Delettion request]] category upon CardView release through the Plugin Manager system)</small>
[[Special:MyPage|test]]
 
{{languages}}
 
<div class="LanguageLinks">
 
<table width="100%" style="clear: both; border: 1px solid #aaaaaa; border-collapse: collapse; padding: 0.2em; margin: 0; font-size: 85%; margin: 0 1px;">
 
<tr valign="top" style="background: #EEF3E2">
 
<td style="width: 25px; padding-left: 0.5em;">[[Image:gramps-config-language.png|20px|]]</td>
 
<td style="width: 10px; white-space: nowrap; padding: 4px 1em 0 0.5em; border-right: 1px solid #aaaaaa;">'''[[GRAMPS:Language policy|Languages]]:'''&nbsp;</td><td style="padding: 1px 1em 0; background: #F6F9ED;">
 
[[:{{NAMESPACE}}:{{BASEPAGENAME}}|English]]
 
{{Languages/Lang|bg||}}
 
{{Languages/Lang|ca||}}
 
{{Languages/Lang|cs||}}
 
{{Languages/Lang|da||}}
 
{{Languages/Lang|de||}}
 
{{Languages/Lang|es||}}
 
{{Languages/Lang|fi||}}
 
{{Languages/Lang|fr||}}
 
{{Languages/Lang|he||}}
 
{{Languages/Lang|it||}}
 
{{Languages/Lang|ja||}}
 
{{Languages/Lang|lt||}}
 
{{Languages/Lang|mk||}}
 
{{Languages/Lang|nb||}}
 
{{Languages/Lang|nl||}}
 
{{Languages/Lang|pl||}}
 
{{Languages/Lang|pt||}}
 
{{Languages/Lang|pt-br||}}
 
{{Languages/Lang|ru||}}
 
{{Languages/Lang|sl||}}
 
{{Languages/Lang|sq||}}
 
{{Languages/Lang|sv||}}
 
{{Languages/Lang|sk||}}
 
{{Languages/Lang|ta||}}
 
{{Languages/Lang|zh||}}
 
</td></tr></table></div>
 
  
== Download page scratchpad ==
+
*Feature documentation:[[Start_with_Genealogy|Start with Genealogy]]
  
{{languages|Download}}
+
*[[Gramps_Glossary#active_person|Active Person]] Gramps Glossary definition
'''Research, organize and share your family tree with Gramps.'''
 
  
Gramps is a free software project and community. We strive to produce a genealogy program that is both intuitive for hobbyists and feature-complete for professional genealogists. It is a community project, created, developed and governed by genealogists.
+
*based on the [https://sourceforge.net/p/gramps/mailman/gramps-users/ Gramps-users] archived threads:
 +
:[https://sourceforge.net/p/gramps/mailman/message/36617953/ The Group As name override]
 +
:[https://sourceforge.net/p/gramps/mailman/search/?q=%22unify+similar+surmanes+%3F%3F%22&mail_list=all unify similar surmanes &#91;sic&#93; thread]
 +
:[https://sourceforge.net/p/gramps/mailman/search/?q=%22Group+As+name%22 threads with "Group As name"]
  
{{man note|{{Man menu|'''Current version: {{version}} Released: 2020-01-10'''}}|''Different data format to the GRAMPS 3.4 series. Full Python 3 support only as Python 2 support dropped. Uses GTK+ 3 GUI. Default database is now SQlite. Lot of updates see:.''[[Gramps 5.1 Wiki Manual - What's new?|What's new?]]}}
 
  
== Linux ==
 
  
[[File:Linux_220x261.png|128px|left]]
+
<!--
  
Before upgrading your distribution: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]].
+
{{DEFAULTSORT:How do I...new category location|noreplace}}
 +
[[Category:Tutorial]]
 +
[[Category:WikiContributors]]
 +
[[Category:Addon]]
  
<big>
 
<u>[[Download#Linux distributions|via Distributions]]</u>
 
&nbsp;&nbsp;&nbsp;&nbsp;
 
<u>[[Download#Linux:_Install_latest_version|Latest version ({{version}}) (advanced users only)]]</u></big>
 
{{-}}
 
  
== MS Windows ==
+
<div style="background:lightcyan">
  
[[File:windows_180x160.png|128px|left]]
+
Once the template content is cloned, Edit the page.  Paste the raw '''[[:Category:Tutorials|Tutorials]]''' outline for your new '''[[:Category:How_do_I...|How Do I...]]''' article above the '''See also''' section. This "raw Tutorial outline" might be simply pasting in a copy of a useful thread from one of the Gramps maillists or the Discourse forum.
  
If upgrading from an [[Previous_releases_of_Gramps|earlier release]], before you download, use your '''existing version of Gramps''' to [[How_to_make_a_backup#current_backup_method|backup]] your Family Trees [[#1|[1]]].
+
----
  
The All-In-One installer includes not only the Gramps application but also the language & support libraries. It currently supports Microsoft Windows in all versions [http://windows.microsoft.com/en-au/windows/lifecycle Vista/7] and later. <br />'''''Please note:''' Gtk-3.18 and Python-3.5 dropped support for Windows XP. Gramps can still be run on Windows XP when using older versions of those support libraries eg: Gtk-3.16 & Python-3.4.4''
+
Finding a ''[[Gramps_Glossary|Gramps Glossary]] term'' to link may be easier than choosing the best introductory section in the wiki.  
 +
  <small>&#91;&#91;Gramps_Glossary#active_person|Active Person]]
 +
  &#91;&#91;Gramps_Glossary#P|Primary Object]]</small>
 +
Glossary terms (like [[Gramps_Glossary#active_person|Active Person]] above) are normally lowercase and use an underscore between words. They have a brief description and may already have the introductory text and practical tutorial linked. You can fall back to the Letter index (like using '[[Gramps_Glossary#P|P]]' with [[Gramps_Glossary#P|Primary Object]] above) if you don't know the exact entry.
  
<big><u>[{{github_url}}/releases/download/v{{version_windows_AIO32}}/{{filename_windows_AIO32}}.exe Windows Installer (32-bit) {{version_windows_AIO32}}]</u>
+
Since most of these ''How do I...'' tutorials are likely to have been prompted by a MailList discussion, a set of example 'See also' link are included for reference.
&nbsp;&nbsp;&nbsp;&nbsp;<br />
 
<u>[{{github_url}}/releases/download/v{{version_windows_AIO64}}/{{filename_windows_AIO64}}.exe Windows Installer (64-bit) {{version_windows_AIO64}}]</u></big>
 
  
After downloading the [https://support.microsoft.com/en-us/help/15056/windows-32-64-bit-faq appropriate 32-bit or 64-bit] installer, double-click to install Gramps.  
+
Pointing the ''maillist archived thread'' link to the original message that inspired the tutorial give proper credit for the idea &amp; reveals the background discussion.
  
{{man warn|[[Download#Missing_other_languages|Missing other languages]]|Standard setup is British ''English only''. So, if using a different language (or the American or Australian dialect of English), please be certain to select those extra dictionary and translation (language) files when asked during the installation process.}}
+
Pointing another link to a good search phrase for the archive allows similar discussions to be explored.
=== Missing other languages ===
 
[[File:Microsoft Window Gramps AIO Installer Choose Components-Selection-51.png|right|thumb|450px|Microsoft Window Gramps AIO Installer Choose Components-Selection window.]]
 
If you want to run Gramps in another language other than English and are using the Gramps AIO installer, then you must select it '''''during''''' installation process.
 
  
Otherwise, it will not be available.
+
----
{{-}}
 
{{man tip|Shortcuts|[[File:Gramps.png|48px|right]]When installation is complete, a shortcut will exist on the desktop and two shortcuts will have been added in the Start menu. Only use the first shortcut unless requested by a developer. The console is for diagnostics, benchmarking and troubleshooting rather than genealogical research.<br />1) ''GrampsAIO'''XX''' ''{{version}}''      {{man menu|<--- Shortcut for everyday use of Gramps}}<br>2) ''GrampsAIO'''XX''' ''{{version}}''-console}}
 
  
Normally, when you try to load your old Family Tree and Gramps reports that it needs to be upgraded, you can allow it and the upgraded Tree will be opened. However, if this upgrade fails for any reason, [[How_to_restore_a_backup|'''Create''' a new Family Tree and '''Import''' your back-up]] into the new Tree.
+
Once the tutorial Preview is satisfactory, save a revision of the document. Then clean out the virtual Copy&amp;Paste clipboard cluttering up your tutorial and save a final revision.  
  
To install with the Windows AIO version, please use the download links above. For more information about individual versions, console and debug modes, release notes, et cetera; look at [[GrampsAIO cx freeze-based|this page]] (English only).
 
  
Independent alternatives to the All-In-One installer include the '''Legacy''' MS Windows version [[#2|[2]]] and the Gramps Chocolatey Package [[#3|[3]]].
+
To remove the virtual Copy&amp;Paste clipboard, simply delete everything from the beginning of this section to the bottom of the document. It is all disposable.
  
== Mac OS X ==
+
If the Copy&amp;Paste clipboard is needed again, simply paste the following line at the end of the Edit box, Save a revision, &amp; edit again.(Previewing isn't enough... a revision must be saved.)
 +
<pre>  {{subst:Template:How_do_I}}</pre>
 +
Other wiki [[:Category:Templates|Templates]] can be used as virtual Copy&amp;Paste clipboards in the same way.
  
[[File:macos_200x200.png|128px|left]]
 
  
Before download: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]]. Read the [[Mac OS X:Application package|before installation]] instructions.
+
</div>
 +
[[Write_a_%22How_Do_I...%22_Article|Writing a 'How do I...' article.]]
 +
<pre>
 +
{{subst:Gramps_{{man version}}_Wiki_Manual_-_Preface}}
 +
{{subst:WikiContributorRecruiting}
 +
</pre>
 +
----
  
Supports Apple Mac OS X in all versions 10.5 (Leopard) and later.
+
== (Section) ==
 +
Stub, english (''default'')
 +
{{Stub}}
  
<big><u>[{{github_url}}/releases/download/v{{version_Mac}}/{{Filename_mac_intel}}.dmg Intel {{version_Mac}}]</u></big>
+
{{Stub|fr}}
&nbsp;&nbsp;&nbsp;&nbsp;
+
Stub, french
  
After download: Double-click the .dmg file to mount the disk (note: your browser may do this for you automatically). Next drag the Gramps application to your application folder and double-click to launch it [[#4|[4]]].
+
=== Embeddable Snippets (Subsection) ===
 +
Icons
 +
: {{icon|gram}} Dashboard
 +
: {{icon|peop}} People
 +
: {{icon|rela}} Relationships
 +
: {{icon|fami}} Family Families
 +
: {{icon|ance}} Charts
 +
: {{icon|even}} Events
 +
: {{icon|plac}} Places
 +
: {{icon|geog}} Geography
 +
: {{icon|sour34}} Sources
 +
: {{icon|cite}} Citations
 +
: {{icon|repo}} Repositories
 +
: {{icon|medi}} Media
 +
: {{icon|note}} Notes
 +
:[[Template:Icon/doc|more of the standard icons]]
  
Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. However if this fails for any reason, '''Create''' a new Family Tree and '''Import''' the back-up into this new Tree.
+
<small>
 
+
{|  
{{man tip|Spell Checking:|Gramps uses a different spell checker than the one provided by Mac OS X, with different spelling dictionary requirements. We can't easily provide dictionaries for all of the supported languages in the bundle, but they're easily downloaded from [https://extensions.openoffice.org/ OpenOffice.org's website]. Download the language you want and save it, then navigate to the download in Finder. Most browsers have a downloads window that offers "Show in Finder" in its context menu. Change the file extension from <tt>oxt</tt> to <tt>zip</tt>, then from the context menu select '''Open with... Archive Utility''' to decompress it. In the decompressed folder or perhaps in a subfolder you'll find the dictionary files in pairs, <tt>foo.aff</tt> and <tt>foo.dic</tt>. Some languages have more than one pair with a README file to explain why. Select a pair and copy it to /Library/Dictionaries (you'll have to authenticate with an administrator id and password), and if 'foo' isn't already a language or locale code, make it one. For example, the French package includes several pairs with names like <tt>fr-moderne.aff</tt> and <tt>fr-moderne.dic</tt>. The spell checker doesn't recognize those names, so when you copy them to /Library/Dictionaries you must rename them to <tt>fr.aff</tt> and <tt>fr.dic</tt> or <tt>fr_FR.aff</tt> and <tt>fr_FR.dic</tt>. You can have more than one dictionary pair installed if you use several languages, but one '''must''' match the language you use for Gramps or spell checking won't be enabled at all.}}
+
|+ List object tools
 
 
 
 
An alternative way to download and install Gramps on MacOS can be done using the MacPorts[[#5|[5]]] framework.
 
{{-}}
 
 
 
== <span id="Linux distributions"></span>Linux and BSD distributions ==
 
{{man note|These packages are built and supported by the [https://en.wikipedia.org/wiki/Linux_distribution distros].|If your distribution is not listed you may possibly find it listed on ''Repology''( https://repology.org/metapackage/gramps/versions )<br>Please report any problems with them to the package maintainer.}}
 
Most Linux distributions come bundled with a version of Gramps, though it's not always the most recent version and it may not have been installed by default. Still it is recommended to use the Gramps version that comes with your distribution.
 
 
 
Below are ways to install Gramps on some of the more popular distributions:
 
 
 
{| {{prettytable}}
 
!style="width: 85pt;" | Distribution
 
!GUI Package manager
 
!Current versions
 
!Notes
 
|-
 
|<!-- Distribution        -->[[File:Debianopenlogo-32.png]]''' [[Debian]] '''
 
|<!-- GUI Package manager -->Add/Remove Software
 
|<!-- Current versions    -->Debian 8 ("jessie")(old old stable): Gramps 4.1.1<br>Debian 8 ("jessie")(backports): Gramps 4.2.5<br>Debian 8 ("jessie")(backports-sloppy): Gramps 4.2.8<br>Debian 9 ("stretch") (old stable): Gramps 4.2.5<br>Debian 9 ("stretch")(backports): Gramps 5.0.1<br>Debian 10 ("buster") (stable): Gramps 5.0.1<br>Debian 10 ("buster")(backports) (stable): Gramps 5.1.1<br>bullseye (testing): Gramps 5.1.1<br>[http://packages.debian.org/sid/gramps sid (unstable)]: Gramps 5.1.1
 
|<!-- Notes              -->[http://packages.debian.org/search?keywords=gramps available versions]
 
|-
 
|<!-- Distribution        -->[[File:Ubuntu_32x32.png]]''' Ubuntu '''
 
|<!-- GUI Package manager -->Software Centre
 
|<!-- Current versions    -->Xenial (16.04 LTS): Gramps: 4.2.2<br>Xenial (16.04 LTS): Gramps: 4.2.6 ([https://launchpad.net/~rosco2/+archive/ubuntu/backports Backport])<br>Bionic Beaver (18.04 LTS): Gramps: 5.0.0<br>Disco (19.04): Gramps: 5.0.1<br>Eoan (19.10): Gramps: 5.0.1<br>Focal (Development: 20.04 LTS): Gramps: 5.1.1
 
|<!-- Notes              -->[http://packages.ubuntu.com/search?keywords=gramps&searchon=names available versions]/ (Also see: [https://launchpad.net/~rosco2/+archive/ubuntu/backports Backports])
 
 
|-
 
|-
|<!-- Distribution        -->[[File:Farm-Fresh linux mint.png]]''' Linux Mint'''
+
! style="width: 70px"|
|<!-- GUI Package manager -->Software Manager
+
! style="width: 70px"|
|<!-- Current versions    -->18.x(Gramps 4.2.2~dfsg-1)<br>19.x(Gramps 4.2.8)
+
! style="width: 70px"|
|<!-- Notes              -->Install the most current version of Gramps using the following [https://forums.linuxmint.com/viewtopic.php?t=220159 instructions] from the ''Linux Mint Forums''<br><br>[http://community.linuxmint.com/software/view/gramps Old versions available from Linuxmint]
+
! style="width: 70px"|
 +
! style="width: 70px"|
 +
! style="width: 70px"|
 
|-
 
|-
|<!-- Distribution        -->[[File:Fedora_32x32.png]]''' Fedora '''
+
!{{icon|stock_add}}
|<!-- GUI Package manager -->Add/Remove Software (Gnome)<br>or<br>Software Management (KDE)
+
!{{icon|share}}
|<!-- Current versions    -->Rawhide (Gramps 5.1.1)<br>Fedora 29 (Gramps 5.0.2)<br>Fedora 30 (Gramps 5.1.1)<br>Fedora 31 (Gramps 5.1.1)<br>Fedora 32 (Gramps 5.1.1)
+
!{{icon|stock_edit}}
|<!-- Notes              -->[https://apps.fedoraproject.org/packages/gramps available versions]
+
!{{icon|stock_remove}}
 +
!{{icon|up}}
 +
!{{icon|down}}
 
|-
 
|-
|<!-- Distribution        -->'''[https://www.mageia.org/en/ Mageia]'''
+
! Add
|<!-- GUI Package manager -->|[https://wiki.mageia.org/en/Installing_and_removing_software drakrpm (or rpmdrake)]
+
! Share
|<!-- Current versions    -->Mageia Caulron: Gramps 5.0.1<br>Mageia 6.1: Gramps 5.0.1
+
! Edit
|<!-- Notes              -->[http://mageia.madb.org/package/show/name/gramps Mageia App Db - gramps]
+
! Remove
|-
+
! <small>Move<br /></small>Upwards
|<!-- Distribution        -->''' openSUSE '''
+
! Move<br />Downwards
|<!-- GUI Package manager -->[https://en.opensuse.org/YaST_Software_Management YaST]
 
|<!-- Current versions    -->openSUSE Tumbleweed: Gramps 5.1.1<br>openSUSE Leap 15.1: Gramps 4.2.8<br>openSUSE Leap 15.0: Gramps 4.2.8
 
|<!-- Notes              -->[https://software.opensuse.org/package/gramps available versions]<br>The most recent version can usually be installed from the 'openSUSE BuildService - GNOME:Apps' repository
 
|-
 
|<!-- Distribution        -->'''Slackware'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->14.2: Gramps 4.2.6<br>14.1: Gramps 4.0.3
 
|<!-- Notes              -->[http://pkgs.org/search/?keyword=gramps available versions]<br>[https://slackbuilds.org/repository/14.2/misc/gramps/?search=gramps slackbuilds.org]: Gramps 5.0.0
 
|-
 
|<!-- Distribution        -->'''[https://www.netbsd.org/ NetBSD]'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->NetBSD: Gramps 3.4.4
 
|<!-- Notes              -->[http://pkgsrc.se/databases/gramps3 available versions]
 
|-
 
|<!-- Distribution        -->'''[https://www.freebsd.org/ FreeBSD]'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->FreeBSD: Gramps 4.2.8
 
|<!-- Notes              -->[http://portsmon.freebsd.org/portoverview.py?category=science&portname=gramps available versions] or  [https://www.freshports.org/science/gramps/ FreshPorts -- science/gramps]
 
|-
 
|<!-- Distribution        -->'''TrueOS'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->PC-BSD: Gramps 3.4.8
 
|<!-- Notes              -->[http://web.pcbsd.org/pc-bsd-is-now-trueos/ 2016/09/01 - PC-BSD is now TrueOS]
 
|-
 
|<!-- Distribution        -->'''[https://www.openbsd.org/ OpenBSD]'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->OpenBSD: Gramps 4.2.8
 
|<!-- Notes              -->[http://openports.se/misc/gramps available versions]
 
|-
 
|<!-- Distribution        -->[[File:archlinux-icon-crystal-32.svg]]'''[https://www.archlinux.org/ Arch Linux]'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    --> Gramps 5.1.2
 
|<!-- Notes              -->[https://www.archlinux.org/packages/community/any/gramps/ available versions]
 
|-
 
|<!-- Distribution        -->'''Gentoo Linux'''
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    --> Gramps 5.1.2
 
|<!-- Notes              -->[https://packages.gentoo.org/packages/app-misc/gramps available versions]
 
|-
 
|<!-- Distribution        -->
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->
 
|<!-- Notes              -->
 
 
|}
 
|}
 +
</small>
  
 +
==== [[Help:Formatting|Text formatting]] (Level 2 Subsection) ====
 +
''italic'', '''bold''', '''''bold & italic'''''
 +
===== [[Help:Images#Uploaded_files|How to Add Images to a Gramps WikiMedia Article]] (Level 3 Subsection) =====
 +
[[File:ChartsCategory-desendantfan-fullcircle-9gen-default-50.png|thumb|right|450px|Fig. {{#var:chapter}}.{{#vardefineecho:figure|{{#expr:{{#var:figure}}+1}}}} A screenshot caption]]
 +
[[Image:Gramps-logo.png|Logo]]
  
{{-}}
+
*[[Screenshots|Screenshots]]
 
+
*[[Special:PrefixIndex|Templates]]
== Linux: Install latest version ==
+
====== Annotations of User Activities  (Level 4 Subsection) ======
 
 
If your distribution doesn't ship with Gramps or you wish to install a different version than it ships with, you could try to install the latest version of Gramps manually.
 
 
 
{{man warn|1=Warning before attempting this use your existing installation to [[How to make a backup|make a Gramps XML backup]]|2=This should only be attempted by experienced users, and after you have backed up your Family Tree.
 
  
The version of Gramps that has been included in your distribution will have been tested to work with the components in that distribution. If you try to install a different version of Gramps there is a possibility that the components needed for the new version of Gramps are not available for your distribution, or they are available, but don't work properly. You might not discover that there is a problem till you have already done some work with the new version of Gramps.
+
*<pre>Commands you type at the command line</pre>
  
If you already have Gramps installed, and you are only making a 'point' upgrade (i.e. from Gramps x.y.z to x.y.z+1, e.g. from 3.4.3 to 3.4.4), then it is likely but not certain that Gramps will continue to work. However, if the change is much greater, especially if it is a major version change (e.g. from 2.y.z to 3.y.z), then the danger that it does not work properly is much greater.}}
+
*''Filenames'' or <code>Filenames</code>
  
=== Debian-based ===
+
*<tt>''Replaceable text''</tt>
For [[Image:Debianopenlogo-32.png]]'''[[Debian|Debian-based linux distributions]]''' (Which includes [[Image:Ubuntu_32x32.png]]''' Ubuntu ''') [{{github_url}}/releases/v{{version}} Download the .deb file]. Double-click on the downloaded .deb file or (for some distributions, e.g. Mint Debian) run the following command from the directory where the file was saved (change the filename to match the one you downloaded).
 
  
sudo dpkg -i python3-gramps_{{version}}-1_all.deb
+
*{{man label|Labels}} for buttons and other portions of the graphical interface
  
If you have an error about having unmet dependencies run:
+
*{{man tooltip|hint text}} for roll-over tooltip hints that identify elements of the graphical interface
  
sudo apt-get -f install
+
*Menu selections look like this: {{Man menu|Menu &#x27a1; Submenu &#x25B6; Menu Item}} (always pad unicode symbols like these arrows with spaces so that robot translators see recognizable words) Gramplet selection menus {{man button|&or;}} (''Down Arrowhead'' button)
 +
* Pop-up menu down {{man button|&#x25BC;}} arrowhead, (triangle) button
  
to install the dependencies.
+
*{{man button|Buttons}}  you can click
  
==== Useful command lines ====
+
*{{Man key press|CTRL|D}} see [[Gramps_{{man version}}_Wiki_Manual_-_Keybindings|Keybindings]] for a list of keyboard combinations used in Gramps.
Before upgrading you can[https://sourceforge.net/p/gramps/mailman/message/35460486/]:
 
  
* Find out what version you are running, by using this:
+
*<tt>Anything you type in</tt>
  
    dpkg-query -s python3-gramps
+
*{{checkbox|1|Checked}} - [[Template:Checkbox|Selected Checkbox]] &#x2611; template
 +
*{{checkbox|0|Unchecked}} - Checkbox that is &#x274f; unselected
 +
*[[File:RadioButton_Selected.png|21px]] - Radio button that is ◉ selected
 +
*[[File:RadioButton_Deselected.png|21px]] - Radio button that is &#128280; deselected
  
that queries the package and gives you info about it.
+
== Boxed annotations ==
 +
{{man tip| 1=Title of Tip |2=Tips text.}}
 +
{{man note|Example Note |Notes text.}}
 +
{{man warn|1=WarningTitle/Heading |2=warning text }}</onlyinclude>
  
* If you are committed to an upgrade then make sure you have backed up you Family Trees to Gramps XML then run :
+
-->
 +
=[https://gramps-project.org/wiki/index.php?title=FI:Gramps_5.0_Wiki_Manual_-_Command_Line&action=rollback&from=Bamaustin&token=bc276000868efdc564789e2bc9ac027062b6337e%2B%5C Reverted Edit to 5.0 user manual]=
 +
The 5.0 user manual is not the same as the [https://gramps-project.org/wiki/index.php/FI:Gramps_5.1_Wiki_Manual_-_Command_Line 5.1 user manual]. [[User:Patsyblefebre|Patsy B Lefebre]] ([[User talk:Patsyblefebre|talk]])
  
    sudo dpkg -r python3-gramps
+
:Added the language templates to the 5.1 page but some other page redirects must be missing, because the [https://gramps-project.org/wiki/index.php/Fi:Gramps_5.1_Wiki-k%C3%A4ytt%C3%B6ohje Finnish index page] does show the language name of "suomi" at the top of the page. [[User:Patsyblefebre|Patsy B Lefebre]] ([[User talk:Patsyblefebre|talk]]) 22:17, 24 June 2022 (UTC)
  
this will remove the current gramps package (assuming its a python3 version older versions could be python-gramps )
+
::Needed a REDIRECT from the English titled Finish "fi" page to the "FI" prefixed Finish page, then you need to edit the Finish page at least once for the language template to update and show "suomi", clear as mud! [[User:Daleathan|Daleathan]] ([[User talk:Daleathan|talk]]) 00:26, 25 June 2022 (UTC)
  
* To stop Ubuntu updating gramps (to possibly an older version from Ubuntu!) you may need to run:
+
=First binary for Apple Mac=
 +
The fist binary [*.DMG] was released by Emrys Williams for Gramps 3.1.2 back in 2009
  
    sudo apt-mark hold gramps
+
see the following messages:
 +
* https://sourceforge.net/p/gramps/mailman/message/11259440/ [Gramps-devel] GTK+ native on MAC OS X /  From: Richard Taylor <rjt-g...@th...> - 2005-11-24 08:55:09 / "This should mean that a MAC native pygtk should be possible and hopefully enough of the pygnome stuff to enable GRAMPS in native MAC OS cocoa form."
  
'''Upgrade is then complete.'''
+
* https://sourceforge.net/p/gramps/mailman/message/22433558/  [Gramps-users] Who uses gramps on Apple Mac?  / From: Emrys Williams <emrys...@ev...> - 2009-05-16 08:23:38 / "I'm contemplating trying to organise better support for gramps on mac, somehow or another. I'd like to know how many people are currently using gramps on mac and how they get on."
  
=== For other distributions ===
+
* https://sourceforge.net/p/gramps/mailman/message/22816867/ [Gramps-devel] gramps on mac / From: Emrys Williams <emrys...@ev...> - 2009-06-20 21:26:46 / "Much to my surprise, I now have a gramps built with jhbuild running on Mac!....so I wrote a jhbuild moduleset to build python 2.6.2, and that magically made everything spring to life using the 3.1.2 gramps....So I have some bugs to investigate and some more organisation of the build to do, then I can think about bundling the whole lot up as a one-click-install Mac package. But it does actually work!"
For other distributions, [[Image:Download_link.png|150px|link={{github_url}}/releases/v{{version}}]] the source and follow the instructions for [[Linux:Build from source]]
 
  
== BSD ==
+
* https://sourceforge.net/p/gramps/mailman/message/23201032/ Re: [Gramps-devel] gramps on mac / From: Emrys Williams <emrys...@ev...> - 2009-07-29 12:08:53 / "Ok, try again: I have _now_ produced a binary packaged Gramps application for Mac the Should Just Work, and it's available for download. There's a description at http://www.gramps-project.org/wiki/index.php?title=Using_Gramps_on_Apple_Mac The build environment is also available and (if you have a Mac with Apple Xcode) will build from scratch in about an hour."
  
[[File:Bsd daemon.jpg|128px|left]]
+
* https://sourceforge.net/p/gramps/mailman/message/23259622/ [Gramps-users] Gramps on Mac PPC now available / From: Richard Taylor <rjt-g...@th...> - 2009-08-05 21:16:14 / "The PPC build of Gramps for OS X is now available."
  
Before upgrading your distribution: Use your '''old version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees [[#1|[1]]].
 
  
<big>
+
Before that Gramps could be installed using Macports ( https://sourceforge.net/p/gramps/mailman/message/18932404/ indicates person was using Gramps 2.2.10 ) from about 2006 and even [https://web.archive.org/web/20061011041734/http://developers.gramps-project.org/tiki-index.php?page=Mac+OS+X before that Apple users] could use something called FINK for version 1.0.10 of GRAMPS!
<u>[[Download#Linux and BSD distributions|via Distributions]]</u>
 
&nbsp;&nbsp;&nbsp;&nbsp;
 
<u>[[Download#Linux:_Install_latest_version|Latest version (advanced users only)]]</u></big>
 
 
 
 
 
See also:
 
* [[BSD platforms]]
 
{{-}}
 
 
 
== Live CD ==
 
 
 
{{man warn|Note that both Live CD demonstrations use an old version of Gramps and it is not recommended for general use}}
 
 
 
[[File:Download_link.png|150px|left|link=https://sourceforge.net/projects/gramps/files/gramps-cdrom/lgenealogy-6.1-desktop-i386.iso/download]]
 
'''Linux live CD Demonstration''' includes Gramps {{Version Linux Live CD}} pre-installed to trial, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn..). [[Linux_Genealogy_CD#Download_the_CD|Download the CD]] (727 MB). The [[Linux Genealogy CD|Linux Genealogy CD is based on Ubuntu 10.10 (Maverick Meerkat)]].  If you are interested in Gramps, but are afraid to actually install it or unable to install it (not your PC, windows, no internet at home, work laptop, ...), then try out our [[Linux Genealogy CD]]. It runs without installing on the hard disk and contains a collection of open source, free, genealogy programs. You can then install latest [http://www.ubuntulinux.org/ Ubuntu] and Gramps from the CD anytime you like.
 
{{-}}
 
 
 
=== Online Demonstration ===
 
You can also try an online demonstration of Gramps on rollApp:
 
* https://www.rollapp.com/app/gramps
 
Select '''Launch Online''' then '''Test Drive(Opening/saving files will not be available)'''
 
 
 
{{man note|Note|This is a commercial limited trial and not endorsed by the Gramps-project. Beware of third parties having your genealogical data.}}
 
{{-}}
 
 
 
== Notes ==
 
 
 
[<span id="1">1</span>]
 
Backup to Gramps XML. You will find backup in the Family Tree menu of recent Gramps versions, otherwise use export in the same menu but '''uncheck privacy options''' in the Exporter Assistant in order to export all data. See : [[How to make a backup]]
 
 
 
[<span id="2">2</span>]
 
{{man menu|Note that PortableApps.com use an old version of Gramps and it is not recommended for general use}} An alternative independent '''Legacy''' version is [http://sourceforge.net/projects/portableapps/files/Gramps%20Portable/ GrampsPortable_{{version_windows_portable}}.paf.exe] (29.0 MB)  
 
[http://portableapps.com/apps/education/gramps_portable Portable Gramps from PortableApps.com] includes all dependencies required for Windows. ''Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu.'' By Bart.S - '''[http://portableapps.com/blog/84601 Please report packaging issues to the author.]''' (2012-09-07)
 
 
 
[<span id="3">3</span>]
 
Chocolatey NuGet is a Machine Package Manager, somewhat like apt-get, but built with Windows in mind. [https://chocolatey.org/packages/gramps/ Gramps Chocolatey Package]
 
 
 
[<span id="4">4</span>]
 
For Apple Mac OS X, alternatively, you can click and hold on the disk icon at the top of the window of the mounted disk, and then option-drag to the Applications folder. This will create a new folder containing all the files, including the README and NEWS.
 
 
 
[<span id="5">5</span>]
 
The MacPorts Project is an open-source community initiative to design an easy-to-use system for compiling, installing, and upgrading open-source software on the Mac operating system. https://www.macports.org/ In order to do that run the following command: <code>port install gramps</code> see: [[Mac OS X:Build from source:MacPorts]]
 
 
 
== See also ==
 
* [[Previous releases of Gramps]]
 
 
 
 
 
[[Category:Documentation]]
 
 
 
==Download pages ==
 
 
 
Why does Gramps have two download pages?
 
There is more than one CMS (Content Management Systems) on the website and they weren't designed to play well with others. The legacy WordPress powered site was for a 'pretty' site that was intended make Gramps more appealing to non-technical prospective users.  And then the MediWiki powered wiki was layered in because the Downloadable manual had been lagging behind so badly. (Of course, the Developer resources are managed by yet other systems.)
 
 
*(1) https://gramps-project.org/blog/download/  - this is just a friendly bridging page from the WordPress site into the MediaWiki page.
 
*(2) https://www.gramps-project.org/wiki/index.php?title=Download  - this is the MediaWiki managed page
 
 
 
The boxed Gramps download logo also leads to (2) from https://gramps-project.org/blog/
 
 
 
Would it make more sense to redirect (1) to (2)? (Page 2 with all the OS specific info is kind of intimidating. That's why Sam & I are playing with the MediaWiki content in this sandbox. The multiple OS download/update process is naturally complex. The convoluted writing adds unnecessary confusion. The WordPress Download page (#1) is simply a bit of PR fluff.)
 
 
 
Also the link https://gramps-project.org/download/  redirects to (2).
 
 
 
[[User:GulliblePangolin|GulliblePangolin]] ([[User talk:GulliblePangolin|talk]]) 22:35, 22 January 2020 (UTC)
 
 
 
:: Thanks for the explanation! (Sam is Sam888 right?)[[User:GulliblePangolin|GulliblePangolin]] ([[User talk:GulliblePangolin|talk]]) 21:51, 24 January 2020 (UTC)
 
 
 
{| role="presentation" class="wikitable mw-collapsible mw-collapsed"
 
|[[File:Gnome-important.png]] <strong>Special copyright considerations for [[:Category:WikiContributors|WikiContributors]]: &nbsp;</strong>
 
|-
 
|All edits to this page need to be under two different copyright licenses:
 
*GNU Free Documentation License 1.2 - see [[Gramps:Copyrights|wiki copyright]]
 
*GPL - see [[Gramps:Manualcopyright|manual copyright]]
 
These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: <nowiki>[https://www.gramps-project.org/...]</nowiki>), not via [[Help:Links|internal links]].<br>
 
Also, only use the known [[Gramps_{{Version manual}}_Wiki_Manual_-_Preface#Typographical_conventions|Typographical conventions]]
 
|}<noinclude>
 
  
This template describes the special copyright provision for material which is part of the Gramps wiki manual pages.  
+
https://gramps-project.org/wiki/index.php/Mac_OS_X:Build_from_source:fink
 +
https://gramps-project.org/wiki/index.php/Mac_OS_X:Build_from_source:fink:local
  
As the manual must in the end be distributed in a GPL released package, all edits must be dual licensed, once for the copyright of the wiki, and once for the copyright of the distributed package.
 
  
[[Category:Pretty Templates]]
+
Updated the previous releases page. [[User:CallMeDave|CallMeDave]] ([[User talk:CallMeDave|talk]])
</noinclude>
 

Latest revision as of 23:07, 8 September 2022

Gramps-notes.png

Please use carefully on data that is backed up, and help make it better by reporting any comments or problems to the author, or issues to the bug tracker
Unless otherwise stated on this page, you can download this addon by following these instructions.
Please note that some Addons have prerequisites that need to be installed before they can be used.
This Addon/Plugin system is controlled by the Plugin Manager

Gnome-important.png
🚧 Unreleased add-on

You may install the addon manually if you are interested in helping to test and report issues.
Beta testing involves a significant risk of data loss and corruption. Make a well-labeled backup frequently.

Gnome-important.png
🚧 Work In Progress

This wikipage is a cloned outline from a template. It is a VERY temporary placeholder in my personal discussion area.

Since you are reading this paragraph, then the I have not progressed to the point of trimming out the excess template material. That means the wikipage is certainly not ready for collaborative editing yet. Multiple people editing now might unintentionally overwrite their work. Contact me via the Discourse discussion forum while this page exists as a 'Discussion' page.

See also

The Group As name override
unify similar surmanes [sic] thread
threads with "Group As name"


Reverted Edit to 5.0 user manual

The 5.0 user manual is not the same as the 5.1 user manual. Patsy B Lefebre (talk)

Added the language templates to the 5.1 page but some other page redirects must be missing, because the Finnish index page does show the language name of "suomi" at the top of the page. Patsy B Lefebre (talk) 22:17, 24 June 2022 (UTC)
Needed a REDIRECT from the English titled Finish "fi" page to the "FI" prefixed Finish page, then you need to edit the Finish page at least once for the language template to update and show "suomi", clear as mud! Daleathan (talk) 00:26, 25 June 2022 (UTC)

First binary for Apple Mac

The fist binary [*.DMG] was released by Emrys Williams for Gramps 3.1.2 back in 2009

see the following messages:

  • https://sourceforge.net/p/gramps/mailman/message/11259440/ [Gramps-devel] GTK+ native on MAC OS X / From: Richard Taylor <rjt-g...@th...> - 2005-11-24 08:55:09 / "This should mean that a MAC native pygtk should be possible and hopefully enough of the pygnome stuff to enable GRAMPS in native MAC OS cocoa form."
  • https://sourceforge.net/p/gramps/mailman/message/22433558/ [Gramps-users] Who uses gramps on Apple Mac? / From: Emrys Williams <emrys...@ev...> - 2009-05-16 08:23:38 / "I'm contemplating trying to organise better support for gramps on mac, somehow or another. I'd like to know how many people are currently using gramps on mac and how they get on."
  • https://sourceforge.net/p/gramps/mailman/message/22816867/ [Gramps-devel] gramps on mac / From: Emrys Williams <emrys...@ev...> - 2009-06-20 21:26:46 / "Much to my surprise, I now have a gramps built with jhbuild running on Mac!....so I wrote a jhbuild moduleset to build python 2.6.2, and that magically made everything spring to life using the 3.1.2 gramps....So I have some bugs to investigate and some more organisation of the build to do, then I can think about bundling the whole lot up as a one-click-install Mac package. But it does actually work!"


Before that Gramps could be installed using Macports ( https://sourceforge.net/p/gramps/mailman/message/18932404/ indicates person was using Gramps 2.2.10 ) from about 2006 and even before that Apple users could use something called FINK for version 1.0.10 of GRAMPS!

https://gramps-project.org/wiki/index.php/Mac_OS_X:Build_from_source:fink https://gramps-project.org/wiki/index.php/Mac_OS_X:Build_from_source:fink:local


Updated the previous releases page. CallMeDave (talk)