Difference between revisions of "Fi:Gramps 5.0 Wiki-käyttöohje - Työkalut"

From Gramps
Jump to: navigation, search
(Etsi mahdolliset henkilöiden kahdennukset)
m (Korjaa sukunimien isot alkukirjaimet)
Line 172: Line 172:
 
Voit sitten päättää, tapahtuuko korjaus ehdotetulla tavalla vai ei.
 
Voit sitten päättää, tapahtuuko korjaus ehdotetulla tavalla vai ei.
  
Työkalu löytyy polusta {{man menu|Työkalut->Sukupuun käsittely->Fix Capitalization of Family Names...}}.
+
Työkalu löytyy polusta {{man menu|Työkalut->Sukupuun käsittely->Korjaa sukunimien isot alkukirjaimet...}}.
  
 
{{man warn|Perumisen historia|Tämä työkalu poistaa tämän istunnon perumisen historian. Et voi peruuttaa työkalun tekemiä muutoksia etkä mitään ennen työkalun käyttöä tehtyjä muutoksia. Suositus on, että pysähdys tässä ja otat varmuuskopion, jotta voit tarvittaessa peruuttaa tämän työkalun vaikutukset.}}
 
{{man warn|Perumisen historia|Tämä työkalu poistaa tämän istunnon perumisen historian. Et voi peruuttaa työkalun tekemiä muutoksia etkä mitään ennen työkalun käyttöä tehtyjä muutoksia. Suositus on, että pysähdys tässä ja otat varmuuskopion, jotta voit tarvittaessa peruuttaa tämän työkalun vaikutukset.}}

Revision as of 05:17, 23 July 2018

Edellinen Hakemisto Seuraava


Fig. 12.1 "Tools >..." Menubar - Tools Overview

Tämän luvun aiheena ovat Grampsin tarjoamat Työkalut.

Gramps Työkaluilla voi analysoida eri tavoilla sukututkimusdataa. Yleensä työkalut eivät tuota tuloksia raporttien tai tiedostojen muodossa. Sen sijaan ne näyttävät tulokset välittömästi tietokoneen näytössä. Kuitenkin työkalun ajotuloksia voi tietyissä tilanteissa siirtää myös tiedostoon.

Työkalut

Fig. 12.2 Työkalujen kuvake "Avaa työkalujen ikkuna"

Työkaluja valitaan polulla Työkalut->Työkaluryhmä ->Työkalu .

Vaihtoehtoisesti voit selata kaikkia työkaluja läpi lyhyine kuvauksineen Avaa työkalujen ikkuna kuvaketta napsauttamalla, mikä avaa Työkalun valinta ikkunan.

Gramps-notes.png
Lisää työkaluja

Voit asentaa Grampsiin lisääkin työkaluja Ohjeet>Laajennusten hallinta valinnalla. Laajennuksista Addons.

Työkalun valinta ikkuna

Fig. 12.3 Työkalun valinta - ikkuna - esimerkkinä "Etsi mahdolliset henkilöiden kahdennukset" informaatio

The Työkalun valinta ikkunassa voi selata kaikissa kategorioissa tarjolla olevien työkalujen valikoimaa lyhyine kuvauksineen. Ikkuna avautuu Avaa työkalujen ikkuna ikonista työkalupalkista.

Analysointi ja tutkimus

Tässä ryhmässä olevilla työkaluilla analysoidaan ja tutkitaan sukupuuta muuttamatta sitä. Gramps tarjoaa tällä hetkellä seuraavat Analysoinnin ja tutkimuksen työkalut:

Vertaa henkilöiden tapahtumia

Fig. 12.4 "Vertaa henkilöiden tapahtumia" - "Tapahtumien vertailusuotimen valinta" - ikkuna

Työkalu tekee vertailun valitulle henkilöryhmälle.

Voit käyttää tätä työkalua valinnalla Työkalut->Analysointi ja tutkimus > Vertaa henkilöiden tapahtumia..., joka avaa Tapahtumien vertailusuotimen valinta ikkunan.

Henkilöryhmä valitaan joko aikaisemmin luoduilla käyttäjäkohtaisilla suotimilla käyttämällä Suodin: pudotusvalikkoa, jossa oletusarvo on Koko tietokanta Tai luomalla Käyttäjän suodin muokkain painikkeen kautta Henkilösuotimet ikkunassa uusi suodin. Työkalu ajetaan Toteuta ja tulokset näytetään Tapahtumien vertailutulokset ikkunassa.


Tapahtumien vertailutulokset ikkunassa voit tarkastella tuloksia tai Tallenna nimellä painikkeelle viedä tulokset laskentalomakkeeseen (ODS muotoiseen). Sulje painikkeella suljet raportin.

Fig. 12.5 "Vertaa henkilöiden tapahtumia" - " vertailutulokset" - ikkuna- laajennettu esimerkki


Sukupuun käsittely

Tässä ryhmässä olevilla työkaluilla muutetaan tietokantaa. Niillä enimmäkseen haetaan ja korjataan tiedoissa olevia virheitä. Gramps tarjoaa tällä hetkellä seuraavia työkaluja sukupuun käsittelyyn:

Gramps-notes.png
Huomaa

Muutokset toteutetaan vain sinun nimenomaisella suostumuksella, ainoana poikkeuksena Tarkista ja korjaa tietokanta työkalun automaattiset korjaukset.

Muokkaa tietokannan ylläpitäjän tietoja

Fig. 12.6 "Tietokannan ylläpitäjä" - ikkuna- näyttää hiiren oikealla avautuvan valikon

Tämä työkalu muuttaa tutkijan tietoja, ks. Researcher Information.

Valitse polku Työkalut->Sukupuun käsittely->Muokkaa tietokannan omistajan tietoja.... Tämä avaa Tietokannan ylläpitäjä muokkain ikkunan, johon voit syöttää haluamasi tiedot.

  • Nimi:
  • Katu:
  • Taajama:
  • Paikkakunta:
  • Lääni tai Osavaltio:
  • Valtio tai Liittovaltio:
  • Postinumero:
  • Puhelin:
  • Sähköposti:

Nämä tiedot ovat sukupuukohtaisia ja niitä käytetään tulostettaessa tietoja GEDCOM muodossa.

Hiiren oikealla avautuvassa valikossa on kaksi valintaa:

  • Kopioi DB asetukset tietokannasta -
  • Kopioi DB asetukset tietokantaan -


Etsi tapahtumien kuvauksia

Gramps-notes.png
Huomaa

Henkilönimen muoto tapahtuman kuvauksessa riippuu henkilönimen muodon määrityksestä Muokkaa->Asetukset->Näyttö->Name format

Fig. 12.7 Etsi tapahtumien kuvauksia - Muutokset tehty - ikkuna- esimerkki tuloksesta

Tapahtumakuvaus muodostetaan tapahtuman tiedoista seuraavalla mallilla:

{tapahtuman tyyppi} {Sukunimi}, {Etunimi}

Työkalu käyttää tätä kuvaustapaa, jos tapahtumassa ei ole ennestään kuvausta.

Työkalu löytyy polulla Työkalut->Sukupuun käsittely->Etsi tapahtumien kuvauksia...

Varoitus muokkaushistoriasta avautuu ensin ja valittavana ovat vaihtoehdot Keskeytä ja Jatka työkalun käyttöä.

Kun valintasi on Jatka työkalun käyttöä, työkalu käy läpi sukupuusi ja näyttää sinulle Muutoksia tehty tulosikkunan, jossa on lisättyjen tapahtumakuvausten kokonaismäärä.

Etsi tietoja nimistä

Tämä työkalu käy läpi koko sukupuun ja yrittää löytää tittelit ja lempinimet, jotka voisi liittää henkilön Etunimi-kenttään. Jos liitettäviä tietoja löytyi, nämä tapaukset esitetään taulukkona. Voit sitten päättää, minkä ehdotuksen hyväksyt ja mitä et.

Työkalu löytyy polulla Työkalut->Sukupuun käsittely->Etsi tietoja nimistä....

Varoitus muokkaushistoriasta avautuu ensin ja valittavana ovat vaihtoehdot Keskeytä ja Jatka työkalun käyttöä.

Fig. 12.8 "Etsi tietoja nimistä" työkalun "Etuliitteiden ja liittäjien oletusasetukset" - ikkuna

The Etuliitteiden ja liittäjien oletusasetukset ikkuna avautuu ja voit siinä muokata seuraavia:

  • Etsittävät etuliitteet: de, van, von, di, le, du, dela, della, des, vande, ten, da, af, den, das, dello, del, en, ein, elet, les, lo, los, un, um, una, uno, der, ter, te, die (default)
  • Sukunimiä osittavat yhdistäjät: e, y (default)
  • Yhdistäjät jotka eivät osoita sukunimiä: de, van (default)

Lopetettuasi käynnistä työkalu OK painikkeella.

Fig. 12.9 "Etsi tietoja nimistä" työkalun "Etsi nimiä ja titteleitä työkalu" - tulosikkuna

Raportin valmistuttua näytetään "Etsi nimiä ja titteleitä työkalu" - tulosikkuna.

Työkalun käyttötapa ei ole suomalaiselle tutkijalle aivan selvä.


Extract Place Data from a Place Title

Gnome-important.png
No longer part of Gramps you can download this tool from the third party addons
See: Extract Place Data from a Place Title

Etsi mahdolliset henkilöiden kahdennukset

Fig. 12.10 Etsi mahdolliset henkilöiden kahdennukset - ikkuna- oletusarvo

Tämä työkalu etsii koko sukupuun ja hakee samaa henkilöä mahdollisesti esittäviä tapauksia.

Työkalu löytyy polulla Työkalut->Sukupuun käsittely->Etsi mahdolliset henkilöiden kahdennukset....

Etsi mahdolliset henkilöiden kahdennukset ikkuna avautuu ja siinä tehdään seuraavia valintoja:

  • Hakuraja : valitse pudotusvalikosta Matala(oletusarvo), Normaaali ja Korkea välillä. (Huomaa:Työkalu laskee kahdentumisen mahdollisuuksia desimaalilukuina. Jokainen samanlainen tieto nostaa mahdollisuutta. Jos mahdollisuus on raja-arvoa korkeampi, tapaus raportoidaan. Raja-arvot ovat Matala=0.25, Normaali=1.0 ja Korkea=2.0. Korkealla raja-arvolla tulee todennäköisesti vähemmän osumia.

Valinnat

  • Käytä soundex koodeja hakemaan mahdollisia kahdennuksia. (valiontaruutu päällä oletusarvona)

Lisäksi käytettävissä on seuraavat painikkeet: Ohje tuo sinut tälle sivulle, Peru pysäyttää käsittelyn ja OK aloittaa tietojen käsittelyn.

Valitse OK käynnistääksesi työkalun ja tiedot käsitellään kahdessa vaihteessa.

  • Vaihe 1: Rakennetaan alkuperäiset listat
  • Vaihe 2: Lasketaan mahdolliset kahdennukset

Käsittelystä näytetään tilannepalkki ja riippuu koneestasi ja henkilöiden lukumäärästä käsittely voi kestää jonkin aikaa.


Fig. 12.11 "Mahdolliset sulautukset" tulosikkuna "Löydä mahdolliset henkilöiden kahdennukset" - työkalusta- esimerkki

Kun työkalun ajo päättyy Mahdolliset sulautukset tuloslistan ikkuna näytetään seuraavan sarakkein:

  • Arvio : tästä saat käsityksen henkilöiden samaisuudesta. Mitä korkeampi arvo, sitä todennäköisemmin he ovat yksi ja sama henkilö.
  • Ensimmäinen henkilö
  • Toinen henkilö

Voit kaksoisnapsauttaa valittua riviä tai valita Vertaa painikkeen tarkastaaksesi yksityiskohdat.

Lisäksi käytettävissä on kolme painiketta: Ohje tuo sinut tälle sivulle, Sulje joka sulkee ikkunan ja palaat {man label|Etsi mahdolliset henkilöiden kahdennukset}} ikkunaan ja Vertaa painike jolla siirryt Sulauta henkilöt ikkunaan. Se on selitetty tarkemmin Sulauta henkilöt ikkunassa. Siinä voit valita radiopainikkeella yhden henkilöistä ja sulauttaa mahdollisesti tiedot OK painikkeella, jos henkilöt ovat mielestäsi samoja.

Perupainikkeella palaat Mahdolliset sulautukset tuloslistan ikkunaan.

Korjaa sukunimien isot alkukirjaimet

Työkalu käy läpi koko sukupuun ja aikoo korjata sukunimissä olevat isoja kirjaimia koskevat virheet.

Korjauksissa pyritään tavanomaiseen käytäntöön: sukunimen ensimmäinen kirjain on iso ja loput kirjaimet pieniä. Tästä säännöstä poikkeavat tapaukset esitetään taulukkona.

Voit sitten päättää, tapahtuuko korjaus ehdotetulla tavalla vai ei.

Työkalu löytyy polusta Työkalut->Sukupuun käsittely->Korjaa sukunimien isot alkukirjaimet....

Gnome-important.png
Perumisen historia

Tämä työkalu poistaa tämän istunnon perumisen historian. Et voi peruuttaa työkalun tekemiä muutoksia etkä mitään ennen työkalun käyttöä tehtyjä muutoksia. Suositus on, että pysähdys tässä ja otat varmuuskopion, jotta voit tarvittaessa peruuttaa tämän työkalun vaikutukset.

Varoitus muokkaushistoriasta näytetään ja voit Keskeytä painikkeella lopettaa työkalun käytön tai Jatka työkalun painikkeella edetä työkalun käytössä.


Fig. 12.12 Esimerkki "Fix Capitalization of Family Names" työkalun tuloksista "Ison alkukirjaimen muutokset" - ikkunassa"

Ison alkukirjaimen muutokset" - ikkunassa näytetään nimille muutosehdotukset. Ikkunan listassa on sukunimet, joissa Gramps voi itse muuttaa etukirjaimen oikeaksi (tarkistathan että olet samaa mieltä niistä.). In the Ison alkukirjaimen muutokset tuloslistassa ovat seuraavat sarakkeet:

  • Valitse - Valintaruuduista hyväksyt tai hylkäät kunkin muutoksen (oletusarvona valinta on päällä)
  • Alkuperäinen nimi - Nimi sukupuussa olevassa muodossa.
  • Alkukirjaimen muutos - Nimi muutetussa muodossa.

Valitse siis muutettavat nimet valintaruuduilla ja käytä sitten Hyväksy muutokset ja sulje painiketta. Peru painikkeella hylkäät kaikki muutokset. Edit selection painike avaa ao. henkilön muokkauslehtiön lisätarkastelua ja kohdennettuja muutoksia varten,

Voit asentaa myös "Fix Capitalization of Given Names" työkalulaajennuksen, joka toimii samoin periaattein etunimien kanssa.

Sulauta lainaukset

Tango-Dialog-information.png
Sulauta lainaukset työkalu

sulauttaa toisiinsa täysin sopivat lähteisiin liittyvät lainaukset.


Tämä työkalu löytyy polusta Työkalut> Sukupuun käsittely > Sulauta lainaukset... .

Varoitus muutoshistoriasta näytetään ja pysäyttää työkalun käytön Keskeytä painikkeella tai edetä sen käytössä Jatka työkalun käyttöä painikkeella.

Fig. 12.13 "Sulauta lainaukset" - ikkuna- oletusarvot

Sitten Sulauta lainaukset avautuu ikkuna, jonka otsikko on:Yhteensopivien lainausten lisätiedot ja mediatiedostot kootaan yhteen.

Seuraavat vaihtoehdot on tarjolla:

  • Hakurajan pudotusvalikossa:
    • Sovita yhteen sivun/osan,päivämäärän ja luottamustason perusteella
    • Ikä päivämäärällä (oletusarvo)
    • Ohita luotettavuus
    • Ohita päiväys ja luottamustaso
  • Valinnat
    • Älä sulauta jos lainauksessa on lisätietoja (valintaruutu pois päältä oletusarvoisesti)


Fig. 12.14 "Sulauta" - ikkuna - työkalun tuloksista esimerkki "Sulautuksia tehty" ikkuna

OK painikkeella ajat työkalun ja kun se on tehnyt työnsä, se raportoi sulautusten kokonaismäärän e Sulautuksia tehty ikkunassa.
Katso myös Sulauta lainaukset valinta, joka on käytettävissä Lainaukset-kategorian listanäkymässä

Uudelleen nimeä tapahtumatyyppejä

Tämä työkalu vaihtaa nimettyä tyyppiä olevien tapahtumien tyypin toiseksi.

Työkalu on käytettävissä polulla Työkalut->Sukupuun käsittely->Uudelleen nimeä tapahtumatyyppejä....

Varoitus muutoshistoriasta näytetään ensin ja voit Keskeytä painikkeella poistua työkalusta tai edetä Jatka työkalun käyttöä painikkeella muuttamisessa.

Gnome-important.png
Perumisen historia

Tämä työkalu poistaa istunnon perumisen historian. Et voi peruuttaa työkalun tekemiä muutoksia etkä mitään ennen työkalun käyttöä tehtyjä muutoksia. Suositus on, että pysähdys tässä ja otat varmuuskopion, jotta voit tarvittaessa peruuttaa tämän työkalun vaikutukset.


Fig. 12.15 "Uudelleen nimeä tapahtumatyyppejä" - ikkuna - esimerkki "Uudelleen nimeä tapahtumatyyppejä" työkalusta

Muuta tapahtumatyyppejä ikkuna avautuu:

  • Alkuperäinen tapahtuman tyyppi: syötä tyyppi tekstikenttään tai valitse alkupäinen tapahtuman tyyppi pudotusvalikosta
  • Uusi tapahtuman tyyppi: syötä tyyppi tekstikenttään (voit luoda tässä täysin uuden tyypinkin) tai valitse uusi tapahtuman tyyppi pudotusvalikosta

Esimerkissä muutetaan Syntymä tapahtumatyyppi Kaste tapahtumiksi.

Gramps-notes.png
Käyttäjän tyypit

Käyttäjän tyypit eli muut kuin vakiotyypit eivät näy pudotusvalikossa. Ne voi kuitenkin syöttää tekstikenttiin, joten on mahdollista muuttaa käyttäjän tyyppejä vakiotyypeiksi tai päinvastoin tai vakiotyyppi vakiotyyppiin tai käyttäjän tyyppi toiseen käyttäjän tyyppiin.



Fig. 12.16 "Muuta tyyppejä" - tulosikkuna - esimerkki "Muuta tapahtumatyyppejä" työkalusta

Voit Peruuta painikkeella lopettaa työkalun käytön. OK painikkeella ajat työkalun ja kun se on tehnyt työnsä, se raportoi muutettujen tapahtumien kokonaismäärän.

Gnome-important.png
Tapahtuminen nimeäminen uudelleen

Kun työkalu on suorittanut uudelleen nimeämisen, sitä ei voi peruuttaa tavanomaisesti Peruuta toiminnolla.

Katso myös:

Järjestä uudelleen Gramps ID:t

Reorder Gramps ID


This tool can be used to Reorder your Gramps IDs. Several options are available.

Gnome-important.png
Custom IDs'

If you customized your IDs', all those can be replaced by this tool. So take care before you use this tool!

Fig. 12.17 Reorder IDs

You can use this tool via menu Tools->Family Tree Processing->Reorder Gramps IDs....

The 'Object' column lists the type of ID. Immediately to the left of this column are checkboxes that allow the enabling of changes to individual object types. When checked, the type can be reordered. The 'Object' label is actually a button that can be used to toggle all of the check boxes at once.

The 'Actual' column shows an example of the current ID. The 'Quantity' column show the number of objects.

The 'Format' column can be used to change the ID format for each object type. Note that the format consists of a prefix, the '%04d' and suffix. There MUST be at least a prefix or a suffix, both are allowed. It is recommended to keep these relatively short. The '%04d' defines the length of the numeric portion of the ID, the '4' can be changed, anything from '3' (allowing numbers from 000-999) to '9' (000000000-999999999) is allowed. Changes made here are the same as made in the menu Edit->Preferences... and then select the ID Formats tab. The 'Format' label is actually a button that can be used to reset all the formats to the last used value.

The 'Change' column contains checkboxes for each object type. If this is checked, the IDs for that object will be replaced with new IDs of the 'Format' style, unless 'Keep' is also checked. If there is no check, the ID formats are NOT updated, but the number field within the format is renumbered. The 'Change' label is actually a button that can be used to toggle all of the check boxes at once.

The 'Start' field indicates the starting number used during the renumber operation. The 'Start' label is actually a button that can be used to toggle between start at 0, and start after last current number.

The 'Step' field indicates the interval between numbers during the renumber, '1' is a simple increment, '2' will increment by 2 etc. The 'Step' label is actually a button that can be used to toggle between '1', '2', '5', and '10'.

The 'Keep' column contains checkboxes for each object type. If this and 'Change' is checked, the ID formats for that object will be retained, and the number field within the format is renumbered. The 'Keep' label is actually a button that can be used to toggle all of the check boxes at once.

The Undo history warning will be shown and you can either Stop or Proceed with the tool.

Gnome-important.png
Undo history

Proceeding with this tool will erase the undo history for this session. In particular, you will not be able to revert the changes made by this tool or any changes made prior to it. If you think you may want to revert running this tool, please stop here and backup your database.

When you click 'OK', the tool will show a progress bar.

In different stages the following IDs' are reordered: Reordering People IDs', Reordering Family IDs', Reordering Event IDs', Reordering Media Object IDs', Reordering Source IDs', Reordering Citation IDs', Reordering Place IDs', Reordering Repository IDs' and finally Reordering Note IDs'.

In a next step unused IDs' are searched for and assigned.

During this process the tool will examine each ID to see if it looks like it has been 'customized', if it doesn't look like the previous ID format or the default ID format. This might be the case if the user had entered his own text in the ID field for the object when editing it. It might also occur if the third party GetGOV Addon has been used, as that tool stores the GOV ID in the ID field. If a 'customized' ID is found, it will ask the user if he really wants to replace the ID. The dialog also allows the user to use the same answer for other customized IDs found.

Sort Events

Events appearing on the Event tab on a Person or Family Editor are not sorted in any particular order other than the order that the events were added. The reason for not enforcing any particular ordering, particularly ordering by date, is to allow for the situation where an event was known to have happened but the exact chronology is not. Importing or merging data from an external source can lead to extra events being added to, but out of sequence with, the existing set of events of a person or family.

Events can be manually re-ordered by drag & drop or by use of the re-order buttons on the Events tab. Either way, an event can be moved up or down in the list of events and Gramps will remember the new order when the changes are saved. The new ordering will be used wherever events are shown elsewhere in Gramps, such as on a report.

The order of all events on a tab can also be changed by clicking a column title. For example, clicking the 'Date' column header will sort all the events in date order. However this way of sorting events is temporary and changes to the event order are not preserved when the window is closed.

The drag and drop approach to sorting events is fine for moving a small number of events but is not practical for large scale changes. The Sort Events tool has been designed specifically for this purpose, re-sorting all events in the database or just those associated with a targeted selection of people chosen by using a filter.

You can use this tool via menu Tools->Family Tree Processing->Sort events....

The Undo history warning will be shown and you can either Stop or Proceed with the tool.

Gnome-important.png
Undo history

Proceeding with this tool will erase the undo history for this session. In particular, you will not be able to revert the changes made by this tool or any changes made prior to it. If you think you may want to revert running this tool, please stop here and backup your database.


Fig. 12.18 "Sort Events" - dialog - showing "Tool Options" tab for "Sort Events" Tool

The first option on the Sort Events dialog window is used to define the range of people who's events are to be sorted. The first choice in the list is to apply the sorting to all people in the database. Alternative choices are to apply sorting to ancestors and descendants of a chosen person or to a range of people selected by a custom built person filter. After choosing who the sort should apply to, the next thing to consider is how the events should be sorted. The first option is to sort by date. This is probably the most likely choice, but other event attributes can be chosen too. The final choices are whether to make the events sorted ascending or descending and whether to apply the sort to family events that the selected people belong to as well.


Gnome-important.png
Sorting events

Once completed, this cannot be undone by the regular Undo function.

Sukupuun korjaus

Check and Repair Database

Gnome-important.png
Warning

The Check and repair Database tool performs automatic fixes. Once completed, this cannot be undone by the regular Undo function.

This tool checks the database for integrity problems, fixing the problems it can. Specifically, the tool is checking for:

  • Broken family links. These are the cases when a person's record refers to a family while the family's record does not refer to that person, and vice versa.
  • Missing media objects. The missing media object is the object whose file is referenced in the database but does not exist. This can happen when the file is accidentally deleted, renamed, or moved to another location.
  • Empty families. These are the family entries which have no reference to any person as their member.
  • Parent relationship. This checks all families to ensure that father and mother are not mixed up. The check is also made that parents have different gender. If they have common gender then their relationship is renamed to "Partners".

You can use this tool via menu Tools->Family Tree Repair->Check and Repair Database....

Gnome-important.png
Undo history

Proceeding with this tool will erase the undo history for this session. In particular, you will not be able to revert the changes made by this tool or any changes made prior to it. It is recommended that you please stop here and backup your database; so that you can revert the process of running this tool.

The Undo history warning will be shown and you can either Stop or Proceed with the tool.


Fig. 12.19 "Integrity Check Results" - example result dialog - for the "Check and Repair Database" tool

Any issues found are automatically fixed and the Integrity Check Results dialog will be shown with a summary actions taken.
Otherwise you will see the No errors were found dialog stating that The database has passed internal checks.

Rebuild Gender Statistics

Fig. 12.20 "Gender statistics rebuilt" - result dialog for "Rebuild Gender Statistics" tool

Rebuilds gender statistics for name gender guessing...

You can use this tool via menu Tools->Family Tree Repair->Rebuild Gender Statistics....

Once completed the Gender statistics rebuilt result dialog will be shown.

Rebuild Reference Maps

Fig. 12.21 "Reference maps rebuilt" - result dialog for "Rebuild Reference Maps" tool

This tool rebuilds reference map tables (References items on editors).

You can use this tool via menu Tools->Family Tree Repair->Rebuild Reference Maps....

Once completed the Reference maps rebuilt result dialog will be shown.

Rebuild Secondary Indexes

Fig. 12.22 "Secondary indexes rebuilt" - result dialog for "Rebuild Secondary Indexes" tool

This tool rebuilds secondary indices.

You can use this tool via menu Tools->Family Tree Repair->Rebuild Secondary Indexes....

Once completed the Secondary indexes rebuilt result dialog will be shown.

Remove Unused Objects

This tool will search your database for pieces of information which are not connected to anything else, and then allow you to edit and attach the information or remove them.

You can use this tool via menu Tools->Family Tree Repair->Remove Unused Objects....


Fig. 12.23 "Unused Objects" - dialog example results for "Remove Unused Objects" tool

The Unused Objects dialog is presented.

You can choose from the search option you want to use from the top section of the Unused Objects dialog:

  • Search for events (checkbox checked by default)
  • Search for sources (checkbox checked by default)
  • Search for citations (checkbox checked by default)
  • Search for places (checkbox checked by default)
  • Search for media (checkbox checked by default)
  • Search for repositories (checkbox checked by default)
  • Search for notes (checkbox checked by default)

Select the Find button to run the report, and once completed the results if any will show in the bottom section of the Unused Objects dialog with the following columns shown:

  • Mark Select the row if you want to delete the object (checkbox unchecked by default)
  • - Icon representing the type of object.
  • ID - Gramps internal name for the object.
  • Name - of the object.

To examine the object you must double-click on the row and it will show the appropriate editor for the object allowing you to edit if required.

Mark the objects you want to delete either using the individual checkboxes or using the associated buttons:

  • Mark all
  • Unmark all
  • Invert marks

Once your deletion choices have been made select the Delete button to delete the objects.

When finished you may then use the Close button to exit the tool.

Apuvälineet

This section contains tools allowing you to perform a simple operation on a portion of data. The results can be saved in your database, but they will not modify your existing data. The following utilities are currently available in Gramps:

Find database loop

Fig. 12.24 Find possible loop

The Find database loop utility allows you to verify if you have ancestral loops in the database.

Select this via the menu Tools->Utilities->Find database loop... you will get a Find database loop window. The window has five tabs; Gramps_ID,Parent, Gramps_ID, Child, Family ID.

  1. First Gramps_ID is a reference to the Parent.
  2. Parent (Ancestor on the image) is the person we are looking for a loop.
  3. Second Gramps_ID is a reference to the Child.
  4. Child (Descendant) is the origin of the loop.
  5. Family_ID is a reference to the associated family


Fig. 12.25 Find possible loop in a complex example

In the following complex example, we have multiple ancestral loops :

If we look at the second line, we have :

  1. First Gramps_ID : I0002
  2. Parent is : Father, Child2
  3. Second Gramps_ID : I0001
  4. Child is : Father, Father
  5. Family_ID is : F0000

To understand what happens :

  1. we start at [I0002] Father, Child2.
  2. We continue with his son [I0003] Father, Child3.
  3. We continue with his son : [I0000] Child, Child.
  4. We continue with his son : [I0001] Father, Father.
  5. We continue with his son : [I0002] Father, Child2 ==> HERE, we have a ancestral loop.


To read more about ancestral loops see:

Media Manager

Fig. 12.26 Introduction - page for "Gramps Media Manager" - Tool wizard
Gramps-notes.png

Please update or expand this section.


The Gramps Media Manager is a group of four separate tools accessed via a wizard like dialog that you can access via the menu Tools->Utilities->Media Manager... which will show the first Introduction dialog page with the following information on the tools abilities.

Gramps-notes.png
Introduction

These tools allow batch operations on media objects stored in Gramps. An important distinction must be made between a Gramps media object and its file.

The Gramps media object is a collection of data about the media object file: its filename and/or path, its description, its ID, notes, source references, etc. These data do not include the file itself.

The files containing image, sound, video, etc. exist separately on your hard drive. These files are not managed by Gramps and are not included in the Gramps database. The Gramps database only stores the path and file names.

These tools allow you to only modify the records within your Gramps database. If you want to move or rename the files then you need to do it on your own, outside of Gramps. Then you can adjust the paths using this tool so that the media objects store the correct file locations.


From the Introduction page selecting the Next button (or using the keyboard shortcut Alt+N) you will be shown the Selection page window.

Fig. 12.27 Selection - page for "Gramps Media Manager" - Tool wizard - default

From the Selection page window select from one the four options the actions you want to take and then select the Next button:


Replace substrings in the path

Fig. 12.28 Replace substring settings - page for "Gramps Media Manager" - Tool wizard - default

This tool allows replacing specified substring in the path of media objects with another substring. This can be useful when you move your media files from one directory to another.

Selecting this radio button will bring up a Replace substring settings window where you can type in any string in the Replace text field and the With text field. At any time you can click on the Cancel button or the Back button. Clicking the Forward button will bring up the Final confirmation window.


Convert paths from relative to absolute

Fig. 12.29 'Convert paths from relative to absolute':"Final Confirmation" page for "Gramps Media Manager" - Tool wizard - example

This tool allows converting relative media paths to the absolute ones. It does this by prepending the Base path for relative media paths: as given in the Edit > Preferences > General tab, or if that is not set, it prepends the default User's Directory.

Convert paths from absolute to relative

Fig. 12.30 'Convert paths from absolute to relative':"Final Confirmation" page for "Gramps Media Manager" - Tool wizard - example

This tool allows converting absolute media paths to a relative path. The relative path is relative viz-a-viz the base path as given in the Preferences, or if that is not set, user's directory. A relative path allows to tie the file location to a base path that can change to your needs.

Add images not included in database

Fig. 12.31 'Add images not included in database':"Final Confirmation" page for "Gramps Media Manager" - Tool wizard - example

Check directories for images not included in database, this tool adds images in directories that are referenced by existing images in the database. You will have to import one media item from each sub directory manually. Media Manager does not include sub-directories automatically. All the directory paths shown in the tool will be searched through.

Not Related

Fig. 12.32. "Not related to '...'" - dialog - showing results for "Not Related" Tool

This report will find people who are not related to the selected active person.

You can use this tool via menu Tools->Utilities->Not Related....

You will get a Not related to '...' results dialog which shows a list of all the people that are NOT related to the selected person.

This list gives you:

  • Name
  • ID
  • Parents
  • Tags

From the Name column you can use the right arrow button and down arrow buttons to collapse or expand the grouped Name list. Double clicking on a person will bring up the person edit dialog or family edit dialog.

If you select a person you can use the Tag text field(you can fill in whatever custom tag name you want to use) or use the drop down list to choose an existing tag eg TODO, NotRelated. Use the Apply to add the selected tag to the person(s). This tag will then show up in the Tags column.

Relationship Calculator

Fig. 12.33 "Relationship to '...' " - dialog - showing results for "Relationship Calculator" Tool

The Relationship Calculator when opened will list all people connected, but not necessarily related, to the active person. Select the individual to check if an relationship exist it will be shown in the lower panel. Only blood relationships will display (except for husband-wife relationships). Note "in-law" relationships cannot be displayed.

You can use this tool via menu Tools->Utilities->Relationship Calculator....

Basically, any two people are related if they have an ancestor in common. One of these individuals may actually be an ancestor of the other - such as a great grandparent. Even in the cases of aunts and uncles, you still can calculate the relationship by searching for the common ancestor. In this case, the father or mother of the aunt or uncle will be a grandparent to the nephew or niece.

Basically, siblings (brothers and sisters) are only one generation down from the common ancestor. Cousins (also called "first" cousins) are two generations down from the common ancestor. "Second" cousins are thus, three generations down from the common ancestor - and so on. But when the two people are in different generations, the relationship becomes an aunt or uncle, if that person is only one generation down from the common ancestor. The reverse of an aunt and uncle is a nephew and niece.

After that, everyone is considered a "cousin", but to indicate that they are not in the same generation we use the word "removed" to indicate the number of generations different between the two. For example, my father's "first" cousin is also my "first" cousin but "once removed" (one generation difference between us). My fathers "first" cousin is my own child's "first cousin twice removed" - two generations different.

A full text list of all blood relations and their spouses can be viewed using a Kinship Report.

Verify the Data

Fig. 12.34 "Verify the Data..." - "Data Verify tool" dialog - "General" tab - defaults

This utility allows you to verify the database based on the set of criteria specified by you.

For example, you may want to make sure that nobody in your database had children at the age of 98. Based on common sense, such a record would indicate an error. However, it is not a consistency error in the database. Besides, someone might have a child at the age of 98 (although this rarely happens). The Verify tool will display everything that violates your criteria so that you can check whether the record is erroneous or not. The ultimate decision is yours.

Select this via the menu Tools->Utilities->Verify the Data... you will get a Data Verify Tool window. The window has four tabs; General, Women, Men, Families. Those tabs show a list with criteria and a input field where you can alter the criteria value. In the lists below I show some workable values.

Verify the Data tab pages

Select the criteria you want to run the tool with from the following tabs. If you are OK with the criteria click the Run button (or hit Alt+R and you will be presented with a Data Verification Results window.

Depending on your criteria and your data a list will be shown. Some possibilities of findings are listed below. But there are others.

  • Disconnected individuals (ones with no parent or spouse or child or sibling)
  • old/dead father
  • marriage after death/ before birth
  • large year span for all children
  • early/late marriage
  • young/unborn mother
  • husband and wife with the same surname
  • same sex marriage/ female husband
  • ...
General
  • Maximum age: 90
  • Minimum age to marry: 17
  • Maximum age to marry: 50
  • Maximum number of spouses for a person: 3
  • Maximum number of consecutive years of widowhood before next marriage: 30
  • Maximum age for an unmarried person: 99

The first check box: Estimate missing or inexact dates causes the tool to accept a baptism date if a birth date is not known, and to accept a burial date if a death date is not known. In addition, starting in Gramps version 3.3, it also causes the tool to accept "inexact" dates (i.e., any "legal" Gramps date which is not a fully-specified one (with an explicit day and month and year)).

The second check box: Identify invalid dates will check if the dates are invalid.

Women
  • Minimum age to bear a child: 17
  • Maximum age to bear a child: 48
  • Maximum number of children: 12
Men
  • Minimum age to father a child: 18
  • Maximum age to father a child: 65
  • Maximum number of children: 15
Families
  • Maximum husband-wife age difference: 30
  • Maximum number of years between children: 8
  • Maximum span of years for all children: 25


Data Verification Results window

Fig. 12.35 Data Verification Results window.

After you run the tool you will be presented with the Data Verification Results window.

On the bottom of the window four buttons are available to make a selection easier. Those are Mark all, Unmark all, Invert marks, and Hide marked.

Double-clicking on a row will give you a possibility to view and or edit the data.

With the Close button (or select the keyboard shortcut Alt+C) you close the Results window.

Examples

Two examples from using real data with this tool:

  • The warning showed 'female husband': checking the data I found a family with father : Anna Roelants. Luckily in the Description I read: The marriage of Adam Roelants and Cornelia Crabbe. It was clearly a typo: Anna i.s.o. Adam. Without this Tool it would be very hard to find.
  • The warning showed 'late marriage': checking the data: male person °1738 female person °1756 : marriage X 1804 [Gregorian Calendar] : Everything seemed to be OK: so they (re)married at the age of 66 and 48 years! The warning showed up because the General criteria was set to 60.
Tango-Dialog-information.png
Difference between Verify the Data tool and the Check and Repair Database tool

The Check and Repair Database tool detects inconsistencies in the database structure. The Verify the Data tool, however, is detecting the records that do not satisfy your particular criteria.


Debug

Gnome-important.png
Warning do not use the Debug tools on your working Family Tree

Always create a new empty Family Tree or a copy of your exiting Family Tree for testing.
The tools available in this advanced menu are used for testing only.

Fig. 12.36 "Tools >Debug>..." Menubar - Tools - Debug menu Overview

When the python -O optimise flag is not turned on, an additional Debug entry appears in the Tools menu.

See Command Line: Python options

Check Localized Date Displayer and Parser

Fig. 12.37 "Start date test?" dialog - for "Check Localized Date Displayer and Parser" - Tool

This test tool will create many people showing all different date variants as birth. The death date is created by parsing the result of the date displayer for the birth date. This way you can ensure that dates printed can be parsed back in correctly.

Gramps-notes.png

Please update or expand this section.



Dump Gender Statistics

Fig. 12.38 "Gender Statistics tool" dialog results example - for "Dump Gender Statistics" - Tool

Will dump the statistics for the gender guessing from the first name.

Gramps-notes.png

Please update or expand this section.



Generate Testcases for Persons and Families

Fig. 12.39 "Generate testcases" dialog - for "Generate Testcases for Persons and Families" - Tool - default

The testcase generator will generate some persons and families that have broken links in the database or data that is in conflict to a relation.

The Undo history warning dialog will be shown and you can either Stop or Proceed with the tool.

Gramps-notes.png

Please update or expand this section.



Populate Sources and Citations

Fig. 12.40 "Populate sources and citations tool" dialog - default

This tool generates sources and citations for each source in order to populate the database for testing with significant numbers of sources and citations.

Gramps-notes.png

Please update or expand this section.



Edellinen Hakemisto Seuraava
Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [https://www.gramps-project.org/...]), not via internal links.
Also, only use the known Typographical conventions