Changes

Jump to: navigation, search

De:Installation

29,821 bytes removed, 21:02, 3 October 2021
Replaced content with "{{languages/de|Installation}} == Anwender == Vollständige Download- und Installationsanweisungen für link=Download#Linux, File:windows_32x32..."
{{languages/de|Installation}}
== Letzte veröffentlichte Version Anwender ==
Die zuletzt veröffentlichte Version ist '''Gramps''' {{version}}Vollständige Download- und Installationsanweisungen für [[File:linux_32x32. Es kann seinpng|link=Download#Linux]], dass sie noch nicht zur Installation für deine Umgebung zur Verfügung steht[[File:windows_32x32.png|link=Download#MS_Windows]] und [[File:macosx_32x32. Bitte besuche die png|link=Download#macOS]] findest du auf der [[Download7de|Download]]seite für mehr Informationen-Seite.
==Gramps aktualisierenEntwickler, Paketierer und fortgeschrittene Benutzer ==
{{man warnSiehe Anleitung zum [[Build from source|1=Warnung|2=Wenn du von einer älteren Version '''Gramps aktualisierst''', solltest du vorher diesen Anweisungen folgenBauen aus der Quelle ]] (englisch).}}
Wenn du von einer älteren Version '''Gramps aktualisierst''', solltest du vorher folgende Schritte durchführen: # Verwende deine '''alte Version von Gramps''' zum '''Sichern''' oder '''Export''' deines Stammbaums nach Gramps XML (Du findest Sicherung im Stammbaummenü der aktuellen Gramps Versionen. Sonst verwende Export in demselben Menü, aber deaktiviere die '''vertraulich''' Optionen im Exportassistenten, um alle Daten zu exportieren).# '''Deinstalliere''' deine alte Version von Gramps.# '''Installiere''' die neue Version von Gramps wie weiter unten beschrieben.# '''Öffne''' deinen bestehenden Stammbaum. :# Normalerweise funktioniert öffnen und aktualisiert deine Daten, wenn benötigt. Wenn erfolgreich, speichere die Sicherung, die du erstellt hast, an einem sicheren Ort.:# In dem Fall, dass das Öffnen oder Aktualisieren deines bestehenden Stammbaums fehlschlägt, tue folgendes:::# '''Erstelle''' einen neuen Stammbaum.::# '''Importiere''' deine alten Gramps XML Daten in diesen Stammbaum. ==Zusätzliche Software, von der Gramps profitiert= Siehe auch ===Gramps benötigt die folgenden Programme nicht zwingend, sie verbessern aber seine Funktionalität: * '''Rechtschreibprüfung''': Die Installation von python-gnome2Kommandozeilen-extras und python-enchant stellt das gtkspell Modul und das enchant Modul zur Verfügung, welche die Rechtschreibprüfung in den Notizen ermöglichen.* '''Graphviz''', '''Inkscape'''Dokumentation : Gramps kann damit nette Stammbäume und Graphen erstellen. Diese werden durch das Graphviz Paket erstellt, welches einen Code (dot) wie auch Programme zum erstellen von Grafen (dotty, zum Aufruf von der Kommandozeile) liefert. Dies gib dir als Forscher den größten Einfluss wie deine Grafen aussehen werden, aber es benötigt einen Lernprozess. Eine Alternative, ist einen grafischen Bericht zu erstellen, den Baum in eine svg Datei umzuwandeln, welche du dann öffnen/bearbeiten/aufbereiten kannst in z.B. Inkscape.* '''ttf-freefont''': Nützliche Schriftarten, da sie UNICODE unterstützen und somit fast jedes Zeichen anzeigen können. * '''[http://portland.freedesktop.org/wiki/ XdgUtils]''' ist ein Satz Kommandozeilenwerkzeuge, die Anwendungen bei einer Reihe von Arbeitsplatzintegrationsaufgaben unterstützen. Ungefähr die Hälfte der Werkzeuge konzentrieren sich auf die Aufgaben, die üblicherweise bei der Installation einer Arbeitsplatzanwendung benötigt werden, und die andere Hälfte konzentriert sich auf die Integration in die Arbeitsplatzumgebung während die Anwendung ausgeführt wird. Auch wenn die Arbeitsplatzkomponenten deiner Anwendung auf eine Installationsroutine, Konfigurations- oder Verwaltungswerkzeug begrenzt sind, bieten dir Xdg-utils einfache Möglichkeiten, die Anwenderfreundlichkeit deiner Komponenten durch bessere Integration in die Anwenderumgebung zu verbessern. * '''[httpDe://tilloy.net/dev/pyexiv2/overview.html pyexiv2]''' ist ein Modul, welches Gramps ermöglicht, in Bilder eingebundene Metadaten zu lesen und zu schreiben. Es wird im Metadatenbetrachter und den Bildmetadatengramplets verwendet. Andere Pakete, die auch nützlich sein können: * '''[http://www.freedesktop.org/wiki/Software/desktop-file-utils desktop-file-utils]'': um eine Liste von Programmen zum Öffnen von Mediendateien bei einem Rechtsklick auf ein Bild zu sehen. ==Linux== ===Automatischer Download und Installation von Gramps===Bevor du Gramps von dieser Seite herunterlädst, schaue, ob das Paketdepot deines Betriebssystems die aktuelle Version Gramps_{{man version}} enthält. Du kannst auch [http://sourceforge.net/projects/gramps/files/Stable/ Gramps stabil auf Sourceforge] besuchen und auf die Versionsnummer des obersten Pakets schauen. Um die Verfügbarkeit insbesondere für dein Linux Betriebssystem zu überprüfen sind unten einige Möglichkeiten aufgelistet:{|{{prettytable}}!Linux Betriebssystem!Kommandozeile|_Wiki_Handbuch_-_Kommandozeilen_Referenz#Umgebungsvariablen|<!--Linux Betriebssystem-->Debian basierte Systeme<br>(Ubuntu & Varianten, Mepis,...)|<!--Kommandozeile--><code>sudo apt-get install gramps$GRAMPSHOME</code>Umgebungsvariablen]]|-|<!--Linux Betriebssystem-->Gentoo (und Sabayon)|<!--Kommandozeile--><code>sudo emerge gramps </code>|-|<!--Linux Betriebssystem-->Mandriva|<!--Kommandozeile--><code>sudo urpmi gramps</code>|-|<!--Linux Betriebssystem-->Redhat based systems<br>(Fedora, CentOS* Festlegen von [[Translating_Gramps#.24GRAMPSI18N_.28for_your_locale.)29|<!--Kommandozeile--><code>sudo yum install gramps$GRAMPSI18N</code>|-|<!--Linux Betriebssystem-->OpenSUSE|<!--Kommandozeile--><code>sudo zypper install gramps</code>|} ===Manueller Download und Installation von Gramps===Wenn dein Linux Betriebssystem Repository nicht die aktuelle Version enthält, kann es sein, das du sie von hier herunter laden kannst. Einige hilfreiche Anwender von Gramps haben Pakete für verschiedene Systeme erstellt. Wenn du Glück hast, findest du dein System weiter nachstehend. Wenn es fehlt, kannst du die Entwickler Mailingliste für Vorschläge kontaktieren. ====Ubuntu und Derivate====Depot Pakete für '''Ubuntu''' und Derivate (Kubuntu, Mephis, LinuxMint, ...): sind verfügbar unter [http://sourceforge.net/project/showfiles.php?group_id=25770 Gramps Download Seite]. Siehe [http://sourceforge.net/projects/gramps/files/OldFiles/ Ältere Dateien] für Archive. ====Debian===='''Debian''': die letzte Version sollte sich im ''unstable'' Depot befinden ([http://packages.debian.org/sid/gramps Sid Gramps]) und kann von deinem Paketmanager aktualisiert werden. Das ''testing'' Depot wird 10 Tage später aktualisiert (außer kurz vor einer stabilen Version), siehe [http://packages.debian.org/testing/gramps Testing Gramps]. Veröffentlichte Versionen von Debian ("etch" und "lenny") enthalten ältere Versionen von Gramps, siehe Liste auf [http://packages.debian.org/search?keywords=gramps Versionen von Gramps in Debian]. ====SuSE===='''SuSE''': Richard Bos hat die Gramps Version für OpenSuse zur Verfügung gestellt. Das Repository für OpenSUSE 11.1 ist verfügbar unter [http://download.opensuse.org/repositories/Education/openSUSE_11.1/] oder [http://download.opensuse.org/repositories/home:/cornelisbb/]. Beachte zum Zeitpunkt des Schreibens ist dieses Repository nicht das selbe wie "Education" aus der Repositoryliste und muss manuell als URL hinzugefügt werden. Das Repository für 11.0 ist [http://download.opensuse.org/repositories/Education/openSUSE_11.0/] und für 10.3 [http://download.opensuse.org/repositories/Education/openSUSE_10.3/]. Für frühere Versionen von OpenSUSE (10.2) siehe den Forumseintrag über [http://www.suseforums.net/index.php?s=22f80a050a1e3cffffd590db0813dea9&showtopic=28727&pid=152093&st=0&#entry152093 erfüllen von Gramps Abhängigkeiten für SuSE mit ''rbos'' und SMART]. Es gibt noch [[OpenSUSE_RPM|eine weitere Möglichkeit verwende den openSUSE BuildService]]. ====Mandriva===='''Mandriva''': Neuere Versionen werden manchmal zurück portiert. Um zurück portierte Software zu installieren, musst du das ''backports'' Repository aktivieren (stelle sicher, das du die Anweisungen auf dem [http://wiki.mandriva.com/en/Docs/Basic_tasks/Installing_and_removing_software#Advanced_use:_Backports_and_candidate_updates Mandriva Wiki] verstehst). Wenn die neueste Version nicht im ''backports'' Repository vorhanden ist, kannst du es im ''contrib'' Repository versuchen. ====Fedora===='''Fedora''': Für Fedora Core siehe auf der [http://sourceforge.net/projects/gramps/files/ Gramps download Seite] nach einem Paket mit ''fc'' und der Endung ''.rpm''. Die Alternative zur Installation aus den Quellen, ist das [[Fedora RPM|Erstellen eines PaketsGebietsschema ]] (englisch) von einer rpm spec Datei oder ein Binary aus fedora testing zu installieren. ====Slackware===='''Slackware 13.0''': Gramps 3.2.5 ist verfügbar über [http://www.linuxpackages.net/pkg_details.php?id=13368 LinuxPackages]. ====Verschiedene GNU/Linux Distributionen====Verschiedene GNU/Linux Distributionen haben andere bevorzugte Wege Pakete für Gramps herunter zu laden und zu installieren. Bitte lies vor dem Herunterladen die Installationsanweisungen für deine Distribution. In allen anderen Fällen musst du die Quellpakete [http://sourceforge.net/projects/gramps/files/ herunterladen] (die Datei mit der Endung '.tar.gz') und Gramps manuell installieren. Siehe den Abschnitt installieren aus der Quelle für Details. ===Gnome und KDE===Du kannst Gramps sowohl in GNOME als auch KDE verwenden, es passt nur besser in GNOME, da es in KDE ein paar wenige Probleme mit GTK gibt. [[KDE page|Genauere Informationen über die KDE-Probleme...]] ===Gramps auf Handhelds===Gramps läuft hervorragend auf einigen Handhelds. Anwender waren erfolgreich bei der Verwendung von Gramps auf: * [[Gramps on the EeeInstallation_alternatives|Asus Eee PC]] * [http://gramps-project.org/2011/01/gramps-mobile-interface-part-i/ Gramps Mobile Interface – Teil IInstallationsalternativen] & [http://gramps-project.org/2011/01/gramps-mobile-interface-%E2%80%93-part-ii/ Teil II===Live CD===Wenn du an Gramps interessiert bist, aber Angst hast oder unfähig bist es zu installieren (fremder PC, Windows, kein Internet zu Hause, Firmenlaptop) dann probiere unsere [[Linux Genealogy CD|Linux Genealogie Live-CD]]. Sie läuft ohne Installation auf die Festplatte und enthält eine Reihe von quelloffenen, kostenlosen Genealogieprogrammen. Du kannst dann jederzeit, wenn du möchtest, [http://www.ubuntulinux.org/ Ubuntu 10.10] und Gramps von der CD installieren. ==Windows, FreeBSD, MacOs, Solaris=====Windows===Es gibt drei verschiedene Möglichkeiten, Gramps unter Windows zu Installieren/verwenden. Die Methode, die du wählst, hängt von ''deinen'' Anforderungen und wie viel Arbeit du in die Einrichtung deines Systems strecken willst ab.In der Reihenfolge der Schwierigkeit:* Gramps All-in-one installer (AIOenglisch) - Obwohl noch in der Entwicklung, gibt es mit dem AIO installer die wenigsten Probleme beim Einstieg. Siehe [[All In One Gramps Software Bundle for Windows|Alles in einem Softwarepaket für Windows]] für mehr Informationen.* Gramps Portable - Ermöglicht dir das Starten von Gramps von einem portablen Laufwerk und kann auf der lokalen Festplatte installiert werden. Siehe [httpübersetzen ://portableapps.com/apps/education/gramps_portable PortableApps.com Gramps Portable] für mehr Informationen.* Gramps installer (minimal) - Stabiles Installationsprogramm, aber du musst alle Abhängigkeiten von Gramps vor der Installation von Gramps installieren. Siehe [[Windows_installerTranslating_Gramps#Installation | zuerst Windowsabhängigkeiten installieren.]] Mehr Informationen über jede dieser Installationsmethoden gibt es auf der [[De:DownloadInstalling_your_translation|Download]] Seite. *Weitere Informationen für Windowsanwender befinden sich auf der Seite [[Gramps and Windows|Gramps und Windows]]. ====Installation von der Quelle==== Glücklicherweise haben ein paar Leute hierfür einen [[Windows installerdeiner Übersetzung]] angefertigt. Bis jetzt liegen keine Berichte über schwerwiegende Unterschiede zwischen den offiziellen Builds von Gramps und dem Windows-Installer vor. Daher sieht die Zukunft hoffnungsvoll aus. Aber bitte verwende ihn auf eigenes Risiko. ===Mac OS X=== Eine ready-to-run Anwendung für Mac OS X für Intel und PPC Apple Rechner ist seit September 2009 verfügbar. Es ist sehr ratsam, die Daten vor der Verwendung des Programms sorgfältig zu sichern (besonders, wenn du von einer früheren Gramps Version aktualisierstenglisch). Bitte lies die Installationsanleitung unter [[Mac OS X:Application package]] bevor du das Programm verwendest. ===Free/OpenBSD und Solaris=== Für FreeBSD und Solaris existieren unterhalb experimentelle Anleitungen zur Installation.* Für FreeBSD verwende die #{{bug|3228}}.* Für OpenBSD verwende [httpGewusst wie://openports.se/misc/gramps gramps port]* Die Installation unter BSD ist ähnlich wie die unter Linux, abgesehen von evtl. anderen Paketnamen. Weitere Informationen gibt es auf Ändern der Sprache der [[BSD page|BSD Seite]].* Gramps wurde erfolgreich vom Quellcode installiert auf Solaris 10 (SPARC) und OpenSolaris X86 (2008.05). Bitte schau auf die [[Solaris Platforms|Solaris Seite]] für Schritt für Schritt Anleitung. ==Installation von den Quellen== Gramps 3.4.x ist die aktuelle Hauptversion und ist für einige Distributionen in Paketform verfügbar. Gramps 4.x ist eine neue Version, die andere Anforderungen besitzt. Installation dieser Version ist [[#Gramps_4.x|hier]] beschrieben. === Gramps 3.4.x === ====Allgemeine Anforderungen==== Gramps {{version}} benötigt python 2.6 oder höher, pygtk 2.16 oder höher und librsvg2 ====Benötigte Linux Pakete==== {|{{Prettytable}}|-!Debian /Ubuntu !Fedora /Redhat!Comment|-|python|python |Benötigt (Version 2.6 oder höher)|-|pygtk2|pygtk2|Benötigt (Version 2.16 oder höher)|-|xdg-utils|xdg-utils|Benötigt für Gramps-3.1.x oder höher|-|[http://docs.python.org/library/bsddb.html BSDDB]|[http://docs.python.org/library/bsddb.html BSDDB]|Aktuelle Datenbank|-|rcs|rcs|Empfohlen für den Betrieb|-|python-gnome2-extras|gnome-python2-gtkspell|Empfohlen für den Betrieb (Rechtschreibprüfung)|-|librsvg2-common|librsvg2|Erforderlich für die Erstellung|-|libglib2.0-dev||Erforderlich für die Erstellung|-||librsvg2-devel|Erforderlich für die Erstellung|-|intltool|intltool|Erforderlich für die Erstellung|-||gcc make gettext|Erforderlich für die Erstellung|-|| WebKit-gtk pywebkitgtk| Benötigt für HTML|-|| goocanvas pygoocanvas| Benötigt für HTML|-|| graphviz graphviz-python|Benötigt für einige Berichte und Ansichten|-||Django|Benötigt für http://gramps-connect.org [[Gramps-Connect: Introduction|Gramps-Connect]]|-| python-pyexiv2| pyexiv2| Benötigt für Metadata Viewer und Image Metadata gramplets|-| libosmgpsmap-dev python-osmgpsmap| osm-gps-map| Benötigt für die Geografieansichten|-| gtk2-engines-pixbuf| | Behebt das Prooblem 'Unable to locate theme engine in module_path: "pixmap"'|} Unter Redhat/Fedora kannst du alles oben aufgeführte installieren mit: <pre>sudo yum install python pygtk2 xdg-utils rcs gnome-python2-gtkspell librsvg2 \ librsvg2-devel gnome-common intltool gnome-doc-utils gcc make gettext WebKit-gtk \ pywebkitgtk goocanvas pygoocanvas graphviz graphviz-python Django</pre> Wenn beim Start von Gramps eine Fehlermeldung zu fehlender "GooCanvas2" angezeigt wird, dann muss die `GooCanvas2` nachinstalliert werden.  [[File:Gramps GooCanvas2.png|450px]]   ==== Quellen herunterladen ==== Es gibt zwei Wege an den Quellcode zu gelangen: download a stable version source, or checkout the source from svn. Jetzt ist es Zeit die [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/INSTALL?view=markup INSTALL] und [httpHowto://gramps.svn.sourceforge.net/viewvc/gramps/trunk/README?view=markup README] Datei zu lesen, die dem Code beigefügt sind. Sie enthalten die neuesten Informationen. Details zu jeder download Methode: '''1. Download einer stabilen Version''' * Die letzten stabile Version von Gramps findest du im [http://sourceforge.net/projects/gramps/files/ SourceForge Datei Bereich]. Z.B.:gramps-{{version}}.tar.gz. Entpacke diese Datei in ein Verzeichnis: <code> tar xzvf gramps-zzz.tar.gz</code> wechsele in dieses Verzeichnis:<code> cd gramps-zzz</code>* Wenn du an der letzten Entwicklerversion interessiert bist, versuche es mit SVN ([[Brief introduction to SVNChange_the_language_of_reports#Unstable_development:_.22trunk.22Run_Gramps_in_a_different_language|Kurzanleitung SVN]]. Die SVN-Version von Gramps ist potenziell gefährlich, da sie nicht getestet wurde. Sie kann zu Abstürzen und Datenverlusten führen. Bitte verwende sie mit Vorsicht- und nur mit einer Kopie deiner Daten! '''2. Herunterladen von SVN''' Du kannst eine Zweigversion (ähnlich wie oben) holen oder die letzte allerneuste Version über SVN, wie etwa:  svn co https://svn.code.sf.net/p/gramps/code/tags/gramps-3.4.4/ gramps für die letzte Entwickler Version siehe [[Getting started with Gramps Trunk| Mit Gramps Trunk beginnen]]. ==== Gramps aktualisieren ==== Wenn du eine ältere Version von Gramps aus den Quellen installiert hast, musst du dich entscheiden, was du mit ihr machen willst, bevor du eine neuere Version installierst. Wenn du die alte Version behalten willst, stelle sicher, das du die Anweisungen in der INSTALL Datei in Bezug auf die Verwendung der --prefix Option liest, die festlegt, wo die neue Version installiert wird. Should you just want to do a straightforward replacement instead, make sure that you remove the older version before you install the new version. '''Do not install over the top of the old version.''' As new versions of Gramps are developed, some functionality is occasionally rewritten in different ways. If you install over the top of an existing installation you run the risk that the old code left behind from the old version may be used instead of the new, sometimes with unintended consequences. If you installed from source, the best way of removing the old version is to run<code> als root '''von dort wo du die alte Version installiert hast'''. Verwende den Paketmanager deiner Distribution zur Deinstallation falls deine alte Version als Paket installiert wurde. '''Beachte du solltest die alte Gramps Version verwenden um Sicherungskopien im Gramps-XML Format zu erstellen, bevor du die alte Version entfernst.''' ==== Unter Linux erstellen ==== Gramps bietet ein Skript, dass den Code zur Installation vorbereitet und das Standard configure-Programm aufruft:<code> ./autogen.sh</code> # als normaler Anwender Dieses Skript wird alle fehlenden Pakete bemängeln. Installiere diese (siehe INSTALL-Datei). Das bauen von den Quellen erfordert normalerweise, dass die Entwicklungsversionen der Pakete installiert sind (paketxy-devel). Wenn du möchtest kannst du einen prefix-Pfad für GRAMPs in der autogen.sh setzen, lies hier zu die INSTALL-Datei. Der Standard-Installationsordner ist /usr/local. Wenn autogen.sh erfolgreich gelaufen ist, kann die typische make-Prozedur beginnen:<code> make </code> # als normaler Anwenderdann <code> make install </code> # als root Eine lokale Installation ohne root-Rechte ist möglich, Anweisungen (in Englisch) sind in der INSTALL Datei enthalten, am wichtigsten ist es muss ein <code>--prefix=</code> und ein <code>--with-mime-dir=</code> Argument in <code>autogen.sh</code> hinzugefügt werden. ====Mac OS X:Erstellen aus der Quelle==== Es gibt mehrere verschiedene Wege Gramps unter Mac OS X aus der Quelle zu erstellen. Einen Überblick über das Erstellen aus der Quelle findest du unter [[Mac OS X:Build from source]]. [[Mac OS X:Build from source:MacPorts|Macports]] und [[Mac OS X:Build from source:fink|fink]] Versionen von Gramps wurden verwendet. Die neueste Version von MacPorts Gramps ist '''{{version_MacPort}}'''.Die letzte offizielle instabile fink Version ist '''3.0.4''' für Mac OS X 10.5 auf PPC und Intel.Es gibt aktuell keine offizielle stabile fink Version von Gramps. (Stand Februar 2012) Anweisungen zur Erstellung von einer vor-kompilierten Binär Version (Mac OX X Anwendungspaket) findest du unter [[Mac OS X:Build from source:Application packageanderen Sprache ausführen]]. Einige Diskussionen über frühere Versuche finden sich unter [[Mac OS X:Build from source:gtk-osx]] mit Fehlerberichten auf [[Mac OS X:Build from source:gtk-osx:bugs]] Einen älteren Ansatz zum erstellen findest du unter [[Mac OS X:Build from source:Native OS X]]. === Gramps 4.x === ==== General requirements ==== Gramps 4.0 requires python 2.7 or python 3.2 or greater. At the moment, python 2.7 is still the most stable way to use Gramps!Also needed are GTK 3.0 or greater, pygobject 3.3.2 or greater, cairo, pango, pangocairo with introspection bindings (the gi packagesenglisch), librsvg2 (svg icon view), xdg-utils. Furthermore, bsddb3 is required for Python 3.2 (not python 2.7). ==== Full install walkthrough Ubuntu derivatives====Following walkthrough was done on a clean install of Kubuntu 13.04 which did have the GTK applications firefox, inkscape and gimp installed. Equal steps should be done on other platforms.  sudo apt-get install subversion svn co https://svn.code.sf.net/p/gramps/code/branches/maintenance/gramps40 gramps40 cd gramps40 sudo apt-get install intltool python setup.py build sudo apt-get install python-gobject python-gi python-cairo python-gi-cairo sudo apt-get install gir1.2-freedesktop gir1.2-pango sudo apt-get install gir1.2-gtk If you now run python Gramps.py -vyou should see all required packages are found. You can now start Gramps locally with the command  python Gramps.py  To install optional components, do the following:  sudo apt-get install python-pyicu graphviz rcs gir1.2-webkit-3 This gives all the easy optional functionality in Gramps. The rest is not yet present in Ubuntu 13.04, so if you want them, you need to compile them '''spell checking'''Remove first present version, check that this command does not remove programs you use! sudo apt-get remove libgtkspell-3-0 python-gtkspellcheck Now we obtain the code to build this package sudo apt-get install mercurial hg clone http://hg.code.sf.net/p/gtkspell/code gtkspell-code cd gtkspell-code sudo apt-get install build-essential sudo apt-get install libgirepository1.0-dev sudo apt-get install valac libgtk-3-dev aclocal ; autoheader; automake ; autoconf ./autogen.sh make sudo make install sudo cp /usr/local/lib/girepository-1.0/GtkSpell-3.0.typelib /usr/lib/girepository-1.0/ sudo cp /usr/local/lib/libgtkspell3-3.* /usr/lib/ '''osmgpsmap'''The geography view needs patches which are not included yet in the official version. sudo apt-get install git git clone git://github.com/nzjrs/osm-gps-map.git cd osm-gps-map sudo apt-get install libsoup2.4-dev gnome-common gtk-doc-tools ./autogen.sh --prefix /usr make sudo make install Wenn beim Start von Gramps eine Fehlermeldung zu fehlender "OSM GPS Map" angezeigt wird, dann muss die `OSM GPS Map` nachinstalliert werden.  [[File:Gramps-OSMGPSMap.png|450px]]  '''gexiv2'''Minimally version 0.5 is needed, but only 0.4 is available in 13.04. So remove 0.4 if present, and we add 0.5 or later ourselves. Obtain it from [http://www.yorba.org/download/gexiv2/], I downloaded 0.6.1, and extracted it in directory ''libgexiv2-0.6.1''. To install this  cd libgexiv2-0.6.1 sudo apt-get install exiv2 libexiv2-dev ./configure --enable-introspection --prefix=/usr make sudo make install Wenn beim Start von Gramps eine "gexiv2" Fehlermeldung angezeigt wird, dann kann der Fehler mit der Nachinstallation von `gexiv2` behoben werden. [[File:Gramps GEXIV2.png|450px]]  '''run Gramps'''You can now use gramps from the source directory with python Gramps.py You could install Gramps, but you better wait for a packages distributed from [http://sourceforge.net/projects/gramps/files/] and install those via your package manager '''look and feel'''Normally, Gramps does not look that nicely when not used on Gnome desktop. To remedy this, install a theme switcher. You can edit configuration files if you don't like to install these dependencies, see eg [https://wiki.archlinux.org/index.php/GTK%2B#GTK.2B_3.x]  sudo apt-get install gnome-tweak-tool
You can search on gtk 3 themes in your package manager and install one that you like. For example, install clearlooks:
sudo apt-get install clearlooks-phenix-theme
then use the gnome-tweak-tool to switch to that. For KDE you need to go also to Settings->Appearance->GTK and set the GTK 3 theme there to the one you installed.
 
==== Full install walkthrough Windows ====
On windows, you can install [https://www.virtualbox.org/ virtualbox] and then install K/X/Ubuntu as indicated above, which will give you linux in windows.
 
The native windows support for Gramps 4.0 is being worked on. You find the current walkthrough [[Run_Gramps40_for_Windows_from_source_using_Python_2.7.3|on the dedicated page]]
==== Linux Paket Anforderungen ====
 
Benötigt
 
{|{{Prettytable}}
|-
!Debian /Ubuntu
!Fedora /Redhat
!Comment
|-
|python
|python
|Benötigt (Version 2.7 oder neuer)
|-
|python-gtk2
|pygtk2
|Benötigt (Version 2.? oder neuer)
|-
|python-cairo python-gi-cairo
|?
|Required
|-
|gir1.2-pango-1.0
|?
|Required
|-
|gir1.2-gtk
|?
|Required is GTK 3.6+
|-
|[http://docs.python.org/library/bsddb.html BSDDB]
|[http://docs.python.org/library/bsddb.html BSDDB]
|Current backend, python3-bsddb3 for python 3!
|-
|xdg-utils
|xdg-utils
|Benötigt für Gramps-3.1.x oder neuer
|-
|python-pyicu
|?
|Required for correct sorting
|-
|libgtkspell-3-0 python-gtkspell
|?
|Required spell checking
|}
 
Zum Erstellen benötigt
 
{|{{Prettytable}}
|-
!Debian /Ubuntu
!Fedora /Redhat
!Comment
|-
|librsvg2-common
|librsvg2
|Zum Erstellen benötigt
|-
|python-dev libglib2.0-dev
|glib2-devel
|Zum Erstellen benötigt
|-
|python-gobject-dev libgirepository1.0-dev
| ?
|
|-
|libcairo2-dev python-cairo-dev
| ?
|
|-
|
|librsvg2-devel
|Zum Erstellen benötigt
|-
|intltool
|intltool
|Zum Erstellen benötigt
|-
|
|gcc make gettext
|Required for building
|}
 
Dringend empfohlen
 
{|{{Prettytable}}
|-
!Debian /Ubuntu
!Fedora /Redhat
!Comment
|-
|
|
| osmgsmap
|-
| graphviz
| graphviz graphviz-python
| Für einige Berichte und Ansichten benötigt
|-
|python-pygoocanvas gir1.2-goocanvas-2.0-9
|?
|
|-
|python-pyexiv2
|?
|exiv data on pictures
|}
 
Optional
 
{|{{Prettytable}}
|-
!Debian /Ubuntu
!Fedora /Redhat
!Comment
|-
|python-gtkspell
|gnome-python2-gtkspell
|Suggested for running (spell check). Included in the python-gnome2-extras package in older Debian distributions.
|-
|rcs
|rcs
|Suggested for running
|-
| python-webkit python-gtkmozembed
| WebKitgtk pywebkitgtk
| Required for the HTML view
|-
| python-pygoocanvas gir1.2-goocanvas-2.0-9
| goocanvas pygoocanvas
| Required for [[Graph View]]
|-
|
| Django
| Benötigt für http://gramps-connect.org [[Gramps-Connect: Introduction|Gramps-Connect]]
|-
| python-pyexiv2
| pyexiv2
| Required for the Metadata Viewer and Edit Exif Metadata gramplets
|-
| libosmgpsmap-dev python-osmgpsmap
| osm-gps-map
| Für die Geografieansichten benötigt
|-
| gtk2-engines-pixbuf
|
| Solves issue with 'Unable to locate theme engine in module_path: "pixmap"'
|}
 
Unter Redhat/Fedora kannst du alles oben aufgeführte mit folgendem Befehl installieren:
 
<pre>
sudo yum install python pygtk2 xdg-utils rcs gnome-python2-gtkspell librsvg2 \
librsvg2-devel intltool gnome-doc-utils gcc automake autoconf autogen \
gettext WebKitgtk pywebkitgtk goocanvas pygoocanvas graphviz graphviz-python \ Django pyexiv2 inkscape ImageMagick
</pre>
 
====Obtaining the source====
 
There are two ways to get the source code: download a stable version source, or checkout the source from svn. Please, now is the time to read the [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/INSTALL?view=markup INSTALL] and [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/README?view=markup README] files accompanying the code. They come with the most recent information. Details on each download method:
 
'''1. Download a stable version'''
 
* The latest stable version of Gramps can be downloaded from the [http://sourceforge.net/projects/gramps/files/ Gramps SourceForge file area]. Eg: gramps-{{version}}.tar.gz. Extract this file into a directory:
<code>
tar xzvf gramps-zzz.tar.gz
</code> and then go into this directory:<code>
cd gramps-zzz
</code>
* If you are interested in testing out the very latest development versions of Gramps, they can be obtained from SVN, see [[Brief introduction to SVN#Unstable_development:_.22trunk.22|Brief introduction to SVN]]. The SVN versions of Gramps are potentially very dangerous as they have not been extensively tested - especially the "trunk" version which contains features that may still be partly implemented. Be aware that they may be prone to crashing and cause extensive data loss. Please use with extreme caution - and only ever on a copy of your data!
 
'''2. Download from SVN'''
 
You can get a branch version (similar as above) or the latest bleeding-edge version through SVN. You can download a specific release via a tag, or you can download the latest development.
First, you need subversion installed, eg on Debian based linux:
sudo apt-get install subversion
 
Then, download a tagged version:
 
svn co https://svn.code.sf.net/p/gramps/code/tags/gramps-4.0.0/ gramps400
 
or latest development:
 
svn co https://svn.code.sf.net/p/gramps/code/branches/maintenance/gramps40 gramps40
 
 
More info can be found in [[Getting started with Gramps Trunk]].
 
====Upgrading Gramps====
 
If you have an older version of the Gramps source code installed you need to make a decision what you want to do with it before installing a later version. If you wish to keep the old version, make sure that you read the instructions in the INSTALL file regarding the use of the --prefix option to specify where the new version gets installed.
 
Should you just want to do a straightforward replacement instead, make sure that you remove the older version before you install the new version. '''Do not install over the top of the old version.''' As new versions of Gramps are developed, some functionality is occasionally rewritten in different ways. If you install over the top of an existing installation you run the risk that the old code left behind from the old version may be used instead of the new, sometimes with unintended consequences. If you installed from source, the best way of removing the old version is to run<code>
make uninstall</code>
 
as root '''from where you installed the old version'''. Use your distribution's package manager to uninstall if your old version was installed as a package.
 
'''Note that you should use your old Gramps version to export backup copies to GRAMPS XML before removing the old version.'''
 
Local installation without root privileges is possible, instructions are available on the INSTALL file, most importantly one needs to supply a <code>--prefix=</code> and a <code>--with-mime-dir=</code> argument to <code>autogen.sh</code>.
 
=== Siehe auch ===
* $GRAMPSHOME in [[De:Gramps_3.4_Wiki_Handbuch_-_Kommandozeilen_Referenz#Umgebungsvariablen|Umgebungsvariablen]]
* [[Translating_Gramps#.24GRAMPSI18N_.28for_your_locale.29| $GRAMPSI18N (for your locale) ]] (englisch)
* [[Installation_alternatives]] (englisch)
* [[Translating_Gramps#Installing_your_translation]] (englisch)
* [[Howto:Change_the_language_of_reports#Run_GRAMPS_in_a_different_language]] (englisch)
[[Category:De:Documentation]]
[[Category:Developers/Installation]]
[[Category:Developers/Packaging]]
5,814
edits

Navigation menu